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Preface

About This Guide Welcome to Xcalibur®, the Thermo Electron mass spectrometry data 
system. Xcalibur includes all the software needed to create, search, and 
edit libraries.

This Xcalibur Getting Productive manual guides you through the following 
procedures:

• How to create and edit custom libraries for MS, MS/MS, or MSn 
spectra

• How to search multiple libraries 

• How to print library search results in custom-designed reports 

Related
Documentation

In addition to this guide, Thermo Electron provides the following 
documents for Xcalibur 2.0:

• Administrator’s Guide: Configuring Xcalibur Software for Compliance with 
21 CFR Part 11

• Getting Productive: Processing Setup and the Analysis of Quantitation Data

• Getting Productive: Qualitative Analysis

• Getting Productive: Quantitative Analysis

• Getting Productive: Creating and Searching Libraries

• Getting Productive: Xreports

• Help available from within the software
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Preface
Safety and Special
Notices

Make sure you follow the precautionary statements presented in this guide. 
The safety and other special notices appear in boxes.

Safety and special notices include the following:

Contacting Us There are several ways to contact Thermo Electron. 

Assistance For new product updates, technical support, and ordering information, 
contact us in one of the following ways:

Visit Us on the Web

www.thermo.com/finnigan

Contact Technical Support

Phone: 1-800-685-9535
Fax: 1-561-688-8736
techsupport.finnigan@thermo.com

Contact Customer Service

In the US and Canada for ordering information:
Phone: 1-800-532-4752
Fax: 1-561-688-8731

International contacts for ordering information: 
Visit www.thermo.com/finnigan for the current listing.

CAUTION    Highlights hazards to humans, property, or the environment. 
Each CAUTION notice is accompanied by an appropriate CAUTION 
symbol. 

IMPORTANT  Highlights information necessary to avoid damage to 
software, loss of data, invalid test results, or information critical for 
optimal performance of the system.

Note  Highlights information of general interest.

Tip  Helpful information that can make a task easier.
viii Xcalibur: Getting Productive with Libraries Thermo Electron Corporation
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Preface
Changes to the Manual
and Online Help

To suggest changes to this guide or to the Help, use either of the following 
methods:

• Fill out a reader survey online at www.thermo.com/lcms-techpubs 

• Send an e-mail message to the Technical Publications Editor at 
techpubs.finnigan-lcms@thermo.com 
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries ix
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Chapter 1 Overview of Library Browser

The Library Browser is part of Xcalibur®, the Thermo Electron mass 
spectrometry data system.

This chapter gives you an overview of the library tools in Xcalibur and how 
to use them to create and use personally customized libraries. The 
introduction describes the basic features of Library Browser and outlines 
what is covered in this manual. A Quick Reference Guide summarizes the 
steps for creating, editing, and searching custom libraries and printing 
reports of the results. 

This chapter also provides information about how to choose a peak 
detection algorithm for Xcalibur to use when performing library searches. 

This chapter contains the following sections:

• Quick Reference Guide

• Specifying the Peak Detection Algorithm

Note   Throughout this manual, the term Library Browser is used 
synonymously with the term NIST MS Search to refer to the NIST MS 
Search desktop.
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 1



1 Overview of Library Browser
Quick Reference Guide
Quick Reference
Guide

Figure 1 is a Quick Reference Guide that provides a one-page summary of 
the steps you perform to create, edit, and search libraries and to print reports 
by using Xcalibur.

First, create a custom user library of MS/MS or MSn spectra, one entry at a 
time. To include a spectrum in a library entry, display a (qualitative) .raw 
file data in Qual Browser. In Qual Browser, you can enhance a spectrum by 
averaging several scans and by subtracting background scans. Then export 
the enhanced spectrum to Library Browser. See “Creating a Library Entry 
with Spectral Data” on page 8 for more information on this process.

Second, when the spectrum is exported to Library Browser, you can edit the 
spectrum information. For example, you can change the name of the entry 
or specify the molecular weight or the CAS (Chemical Abstract Service) 
registry number. You can even attach a chemical structure to the library 
entry. You can also select which mass-to-charge ratios to include in the 
entry. See “Editing a User Library” on page 16 for more information.

Finally, Xcalibur provides three ways to search libraries and print custom 
reports:

• Automatically, by using raw (.raw) or result (.rst) files in Sequence Setup

• Manually, by using a single spectrum in Qual Browser

• Manually, by using a single spectrum exported to Library Browser

Refer to “Setting Up to Search Libraries Automatically” on page 42, 
“Initiating a Library Search from Qual Browser” on page 58, and 
“Searching a Library by Using Library Browser” on page 62 for more 
information on searching.

Use the Qual view options in the Processing Setup window to specify a 
processing method to print reports automatically. Then reference this 
processing method to specify a sequence of files in Sequence Setup. When 
you reprocess a sequence, Xcalibur prints the reports.

If you manually search for search results that match a single spectrum, print 
the results by using the command File > Print either in Qual Browser or in 
Library Browser.

Note  For MS/MS and MSn spectra, however, be careful to delete none 
of the masses that Xcalibur detected because the presence of a particular 
mass-to-charge ratio, rather than its intensity, is an essential criterion for 
identification of a compound.
2 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 1 Overview of Library Browser
Quick Reference Guide
Figure 1. Quick Reference Guide
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1 Overview of Library Browser
Specifying the Peak Detection Algorithm
Specifying the Peak
Detection Algorithm

Specify how Xcalibur finds and processes chromatogram peaks by choosing 
one of three algorithms: ICIS, Genesis, or Avalon. The ICIS peak detection 
algorithm has been designed for MS data and has superior peak detection 
efficiency at low MS signal levels. This is the Xcalibur default peak detection 
algorithm. The Genesis peak detection algorithm is the original Xcalibur 
peak detection algorithm. This algorithm has been provided for backward 
compatibility with Xcalibur 1.0 studies. The Avalon peak detection 
algorithm supports detectors other than MS and detects negative 
chromatographic peaks and shoulders more accurately than Genesis or 
ICIS. 

For the examples in this manual, specify the ICIS algorithm:

1. Open Qual Browser from the Roadmap view of Xcalibur Home Page.

2. Open a .raw file and click the pin in the Chromatogram view to select 
it.

3. Right-click the Chromatogram view and choose Peak Detection and 
then either Set Peak Detection Algorithm and Detect in this Plot or 
Set Peak Detection Algorithm and Detect in all Plots (see Figure 2).

Figure 2. Chromatogram view
4 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 1 Overview of Library Browser
Specifying the Peak Detection Algorithm
4. Select the ICIS peak detection algorithm. Xcalibur automatically 
integrates the peak using the ICIS algorithm.

5. Specify mass tolerance and mass precision (see Figure 3).

a. Select Display > Mass Options. The Global Mass Options dialog 
box appears.

b. Specify a mass tolerance bandwidth in the Mass Tolerance box to 
calculate spectrum averages, to add and subtract spectra, and to 
convert profile data to centroid data. Specify the units of mass 
tolerance as mmu or ppm.

c. Specify a mass precision number from 0 to 5 in the Decimals box. 
Xcalibur applies a number of decimal places to mass intensity values 
for data processing calculations. Click OK.

Note  For new processing methods only, you can choose either the ICIS, 
Genesis, or Avalon Xcalibur peak detection algorithm as the default 
setting for each type of detector. From the Roadmap view of the Home 
Page, choose Tools > Configuration and select the appropriate default 
option on the Peak Detection page.

Figure 3. Global Mass Options dialog box
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 5



1 Overview of Library Browser
Specifying the Peak Detection Algorithm
6. Specify the relative scale (see Figure 4).

a. Select the chromatogram view, right-click the view, and choose 
Display Options.

b. Click the Axis tab to display the Axis page.

c. Under the Y-axis Units area, select the Relative option. (Xcalibur 
uses the Relative scale to calculate mass spectral data and the 
Absolute scale to calculate UV/PDA/other data.) Click OK.

Figure 4. Display Options dialog box - Chromatogram Axis page
6 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



Chapter 2 Managing Libraries

Use the Xcalibur data system to create a custom library of MS/MS spectra. 
The Xcalibur data system includes a subset of the NIST mass spectral library 
called nistdemo. The NIST/EPA/NIH Main Library contains more than 
100,000 compounds whose MS-type spectra were obtained primarily in 
electron ionization (EI) scan mode. You might want to create a custom 
library that includes MS/MS spectra or spectra of MSn analyses.

This chapter contains the following sections:

• Creating a Library Entry with Spectral Data

• Editing a User Library 

• Managing the NIST Libraries

• Converting Libraries to Another Format

Note  Refer to the online Help for more information: Choose Help on 
the menu bar in any Xcalibur window. For assistance with Library 
Browser specifically, choose Help > Help Topics on the Library Browser 
menu bar.
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 7



2 Managing Libraries
Creating a Library Entry with Spectral Data
Creating a Library
Entry with

Spectral Data

To create a library entry with MS or MS/MS (or MSn) spectral data, use the 
Qual Browser window. creating a library entry with your spectral data

The procedure in this section uses steroid data. The raw data files are 
included with the Xcalibur data system in the C:\Xcalibur\examples\data 
directory.

To create a library entry, complete the following tasks detailed in this 
section:

• Opening a Raw Data File (.raw) in Qual Browser 

• Viewing a Spectrum in Qual Browser 

• Subtracting Background Spectra 

• Exporting a Spectrum to Library Browser 

Opening a Raw Data File
(.raw) in Qual Browser

To view MS/MS raw data, use the Qual Browser window. Open a data file 
to expand the Qual Browser menu bar.

To display the raw data of a steroids data file

1. Display the Xcalibur Home Page from the Microsoft® Windows® 
Desktop in either of the following ways:

• Click Start > Programs > Xcalibur > Xcalibur. 

• Double-click the Xcalibur shortcut on the desktop.

2. Click the Qual Browser button on the Xcalibur Home Page to display 
the Qual Browser window.

3. Choose File > Open or click the Open button in the toolbar to display 
the Open Raw File dialog box.
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 2 Managing Libraries
Creating a Library Entry with Spectral Data
4. Browse to the Xcalibur\examples\data\steroids14.raw file (see Figure 5).

5. Select the Add: Window option button and click Open to display the 
data for the steroids (see Figure 5).

Leave the Qual Browser window open, and go on to the next section, 
“Viewing a Spectrum in Qual Browser” .

Figure 5. Open Raw File dialog box, showing the selection of 
steroids14.raw
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 9
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Creating a Library Entry with Spectral Data
Viewing a Spectrum in
Qual Browser

To view a mass spectrum, use the interactive cells of the Qual Browser 
window. This procedure continues from the previous section, “Opening a 
Raw Data File (.raw) in Qual Browser” on page 8.

To display a mass spectrum of the raw data in a window containing four 
cells

1. Confirm that Xcalibur displays the Chromatogram view as shown in 
Figure 6. If it does not, do the following:

a. Choose View > Info Bar to hide the Information bar.

b. Click the Maximize button in the upper right corner of the window 
to enlarge the window display area.

c. Choose Grid > Delete > All Cells to display a single cell.

d. Choose View > Chromatogram to display only the chromatogram 
in the cell.

Figure 6. Qual Browser window, showing the Chromatogram view of steroids14.raw
10 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 2 Managing Libraries
Creating a Library Entry with Spectral Data
2. Specify that the raw data appears in a grid of four cells (as shown in 
Figure 7): 

a. Choose Grid > Insert Cells > Left to display two cells in the 
window.

b. Choose Grid > Insert Cells > Below to display four cells in the 
window.

3. Click the lower left cell and choose View > Scan Filters to display the 
scan filter data. The cell lists the filters contained in the total ion current 
(TIC) chromatogram over a specified time range.

Figure 7. Qual Browser window, showing the following views (clockwise from lower left): Scan Filter 
view, (filtered) Chromatogram view, (averaged) Spectrum view, and (unfiltered) 
Chromatogram view
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 11



2 Managing Libraries
Creating a Library Entry with Spectral Data
4. Display a mass range chromatogram in the upper left cell:

a. Click the pin in the upper right corner of the cell to make it active.

b. The last entry in the scan filter list is for a mass range chromatogram 
of all ions between m/z 150 and 375. Click and hold on the last 
entry in the list. Xcalibur surrounds the entry with a box and 
displays a page cursor.

c. Drag the page cursor to the upper left cell and release the mouse 
button. Xcalibur automatically applies the filter and displays the 
mass range chromatogram.

5. Display an averaged mass spectrum in the upper right cell: 

a. Click the pin in the upper right corner of the cell to make it active.

b. Choose View > Spectrum to set up to display a mass spectrum.

c. Click and hold in the upper left cell at a position just to the left of 
the chromatogram peak. 

d. Drag the cursor horizontally across the peak, and release the mouse 
button. Xcalibur displays a mass spectrum in the upper right cell. 
This spectrum is the average of the scans in the retention time range 
that you selected. For example, see the upper right cell in Figure 7. 

Leave the Qual Browser window open, and go to the next section, 
“Subtracting Background Spectra” .

Subtracting Background
Spectra

To subtract background spectra, eliminating background peaks from either 
one range (either side of the chromatogram peak of interest) or two ranges 
(both sides of the chromatogram peak of interest), use the Chromatogram 
view. This procedure continues from the previous section, “Viewing a 
Spectrum in Qual Browser” on page 10.

To select two scan ranges for background subtraction

1. Click the pin button in the upper right corner of the spectrum to 
select it.

2. Choose Actions > Subtract Spectra > 2 Ranges to display the crosshair 
cursor labeled -1.

3. Click and hold on a baseline region in the upper left cell that is close to 
the chromatographic peak of interest. 
12 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 2 Managing Libraries
Creating a Library Entry with Spectral Data
4. Drag the cursor away from the peak of interest and across a few scans 
that are representative of the first scan range to subtract.

5. Release the mouse button to define the first range. The label on the 
cursor changes to -2.

6. Click and hold on a baseline region on the other side of the peak of 
interest. 

7. Drag the cursor away from the peak of interest and across a few scans 
that are representative of the second scan range to subtract 
(see Figure 8).

Figure 8. Qual Browser window, showing background subtracted scans in the Spectrum view 
(upper right)
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 13
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8. Release the mouse button to define the second range.

When you release the mouse button, Xcalibur subtracts an average of 
the selected scans and redraws the Spectrum view. The Spectrum view 
header shows the number of subtracted scans. For example, 
SB: 12 0.52-0.56, 0.92-0.99 indicates the following: 

• Qual Browser has applied background subtraction to the spectrum by 
using a 12-scan average. 

• Retention time ranges used in the subtraction are 0.52 to 0.56 min and 
0.92 to 0.99 min.

Leave the Qual Browser window open, and go on to the next section, 
“Exporting a Spectrum to Library Browser” .

Exporting a Spectrum to
Library Browser

To create a library entry for a custom library, export a spectrum from the 
Spectrum view of Qual Browser to the Library Browser. This section 
continues from the previous section, “Subtracting Background Spectra” on 
page 12.

To export the enhanced spectrum to Library Browser

1. Right-click the Spectrum view (upper right cell) and choose Library > 
Export to Library Browser to export the MS/MS spectrum of the 
steroid to the Library Browser. Xcalibur displays the Library Browser 
windows (see Figure 9). 

Xcalibur converts the mass and intensity data of the spectrum to a text 
file and copies the file to the Spec List pane. The Qual Browser window 
stays open.



 2 Managing Libraries
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Leave the Library Browser windows open, and go on to the next section, 
“Editing a User Library” on page 16.

Figure 9.  Library Search window of Library Browser
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 15



2 Managing Libraries
Editing a User Library
Editing a User Library To edit a user-library entry that contains the MS/MS spectrum you 
exported from Qual Browser, use the following procedure. 

To edit a user library, complete the following tasks detailed in this section:

• Editing Spectrum Information

• Adding an Entry to and Naming a Library 

• Attaching a Chemical Structure to a Library Entry

• Appending Additional Compounds to the User Library

Editing Spectrum
Information

This procedure continues from the previous section, “Exporting a Spectrum 
to Library Browser” on page 14.

To edit MS/MS spectrum information in Library Browser

1. In Library Browser, choose Window > Librarian to display the 
Librarian window. Because the information for the MS/MS spectrum is 
stored as a text file, the source of the data is listed as Text File in the 
Plot/Text pane (see Figure 10).

Figure 10.  Librarian window, showing the spectrum information as a text file
16 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 2 Managing Libraries
Editing a User Library
2. Click the Edit Spectrum button to display the Spectrum Information 
dialog box (see Figure 11). The dialog box displays information specific 
to the spectrum.

3. Change the name of the spectrum reference:

a. Click and drag the cursor in the Name text box to highlight the 
entire text string.

b. Rename the spectrum to give it a more useful name than the default 
text string. For this example, type hydrocortisoneMS2.

Leave the Spectrum Information dialog box open, and go to the next 
section, “Adding an Entry to and Naming a Library” on page 18. 

Figure 11. Spectrum information dialog box showing raw spectrum information
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 17



2 Managing Libraries
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Adding an Entry to and
Naming a Library

To add a library entry to a library and name the library, use Library 
Browser. This procedure shows you how to create a new library, name it, 
and copy the spectrum to the library. It continues from the previous section, 
“Editing Spectrum Information” .

To add a spectrum entry to and name the library

1. In the Spectrum Information dialog box, click Add to Library. This 
displays the Choose Library To Save To dialog box (see Figure 12).

2. In the Choose Library To Save To dialog box, select the library. It can 
be an existing library or a new one. To create a new library, type the 
name of a library in the combo box. For this example, type ms2test.

3. Click OK. Library Browser names the library, copies the spectrum to 
the library, and returns to the Librarian window.

4. In the Librarian window, click the Lib. Search tab to return to the 
Library Search window. 

Leave the Library Browser windows open and go on to the next section, 
“Attaching a Chemical Structure to a Library Entry” .

Figure 12. Choose Library To Save To dialog box, showing the 
ms2test user library 
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Editing a User Library
Attaching a Chemical
Structure to a Library Entry

To attach a chemical structure from the nistdemo list of structures to an 
entry in a custom library, use the following procedure. Also use the 
procedure to attach a structure from a program such as ChemDraw™, 
ChemDraw saves drawings of chemical structures in the .mol file format. 

Because you cannot attach a structure to a text file, set the search parameters 
in Library Browser so that the name of the compound source changes to a 
name other than Text File in the Librarian window. This procedure 
continues from the previous section, “Adding an Entry to and Naming a 
Library” on page 18.

To attach a structure to the entry hydrocortisoneMS2 and change the 
source of the entry from Text File to user library ms2test

1. In the Library Search window, select and then delete the steroids entry 
in the Spec List.

2. Click the Qual Browser button in the task bar at the bottom of the 
monitor screen to display the Qual Browser window. 

3. In the Spectrum view, right-click the mouse button, and choose Library 
> Export to Library Browser. The Library Browser windows open.
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2 Managing Libraries
Editing a User Library
4. Specify the library ms2test: 

a. Choose Tools > Library Search Options to open the Library 
Search Options dialog box. 

b. Click the Libraries tab to display the Available Libs and the 
Included Libs list of libraries (see Figure 13).

c. Confirm that ms2test is listed in the Included Libs list box. If ms2test 
is not in the Included Libs list box, highlight ms2test in the Available 
Libs list box, and click Add. 

d. Click OK to return to the Library Search window.

Figure 13. Library Search Options dialog box
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 2 Managing Libraries
Editing a User Library
5. Select steroids14 in the Spec List pane. Right-click this entry and select 
Library Search. Library Browser finds the entry hydrocortisoneMS2 and 
copies it to the Hit List pane (see Figure 14).

6. Copy the match to the Spec List pane:

a. Select the Hit List entry hydrocortisoneMS2. Right-click this entry 
and select Copy from the shortcut menu. 

b. Move the cursor to the Spec List pane and left click the mouse 
button to make the Spec List pane active.

c. Right-click to display the shortcut menu and select Paste to paste 
the entry hydrocortisoneMS2 to the Spec List window. 

Figure 14. Library Search window, showing the results of searching the library ms2test
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2 Managing Libraries
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7. Choose the Librarian tab to open the Librarian window (see Figure 15).

Figure 15.  Librarian window, showing the ms2test library entry hydrocortisoneMS2
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8. Save the structure of hydrocortisone from the library nistdemo to the 
ms2test entry hydrocortisoneMS2:

a. In the Librarian window, click the Edit Spectrum button in the 
toolbar to display the Spectrum Information dialog box (see 
Figure 16).

b. Click the Attach Struct button to display the Open dialog box and 
search for chemical structure files from other sources. 

Figure 16. Spectrum Information dialog box, showing the name of entry 
edited to hydrocortisoneMS2
Thermo Electron Corporation Xcalibur: Getting Productive with Libraries 23



2 Managing Libraries
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c. In this example, the structure file you need is not available in the 
Open dialog box’s folders. Click Cancel to display the Attach 
Structure To User Spectrum dialog box (see Figure 17). 

d. Click nistdemo in the Get Structure From group box. Then, click 
Open Library.

e. Type hydrocortisone in the Substring Search text box. Then click 
Substring Search. Library Browser scans the nistdemo library and 
finds the MS data and the structure of hydrocortisone.

Figure 17. Attach Structure to User Spectrum dialog box
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f. Click Accept to accept the structure and return to the Spectrum 
Information dialog box (see Figure 18).

Figure 18. Spectrum Information dialog box, showing the structure of 
hydrocortisone from the nistdemo library to be included in the 
user-library entry
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g. Click Add to Library to display the Choose Library To Save To 
dialog box (see Figure 19). 

h. Click OK to close the Choose Library To Save To dialog box and 
return to the Librarian window. The source of the entry 
hydrocortisoneMS2 appears as ms2test. 

Figure 19. Choose Library To Save To dialog box
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9. Highlight the entry in the Spec List that causes the Text File designation 
to appear in the Plot pane. Click the Delete From Library button in 
the toolbar to delete the entry. 

The warning shown in Figure 20 appears. Click OK to close the 
warning dialog box.

10. Click the Lib. Search tab to return to Library Browser’s Library Search 
window. 

11. Double-click the entry hydrocortisoneMS2 in the Spec List.

The chemical structure of hydrocortisone is attached to the ms2test 
library entry hydrocortisoneMS2.

Leave the Library Browser windows open, and go on to the next section, 
“Appending Additional Compounds to the User Library” .

Appending Additional
Compounds to the User

Library

To add compounds to a user library, use the Qual Browser window. This 
section describes how to append the three remaining steroids in the 
steroids14.raw file to the ms2test user library. The compounds are:

• Deoxycorticosterone

• Methyltestosterone

• Progesterone

This procedure describes exporting spectra to Library Browser using 
unenhanced spectra. Refer to the related sections “Subtracting Background 
Spectra” on page 12 and “Attaching a Chemical Structure to a Library 
Entry” on page 19 for more information. Those procedures should be 
applied to unenhanced spectra, when possible, before the procedure in this 
section is applied to them. This procedure continues from the previous 
section, “Attaching a Chemical Structure to a Library Entry” on page 19. 

Figure 20. Warning bar that appears after you delete an entry from 
the Spec List
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To append three library entries of MS/MS steroid data to the user library 
ms2test

1. Click the Qual Browser button in the task bar at the bottom of the 
monitor screen to display the Qual Browser window.

2. Display the MS/MS spectrum of the second steroid peak:

a. Confirm that the pin in the Spectrum view (upper right cell) in 
Qual Browser is active. 

b. Move the cursor to the Chromatogram view in the lower right cell. 
Then, click and hold just to the left of the second chromatographic 
peak. 

c. Drag the cursor horizontally across the peak to average the scans you 
select. Xcalibur displays the spectrum in the Spectrum view.

3. Right-click the mass spectrum to display a shortcut menu. Then, choose 
Library > Export to Library Browser to export the spectrum. Xcalibur 
displays a message box, as shown in Figure 21.

4. Click Prepend to add the entry to the Clipboard window.

5. Edit the spectrum information:

a. Choose Window > Librarian in Library Browser to display the 
Librarian window.

Figure 21. Message box, asking whether to overwrite or to append the 
spectrum to be exported to Library Browse
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b. Select the unedited entry in Spec List pane as shown in Figure 22.

c. Click the Edit Spectrum button to display the Spectrum 
Information dialog box. 

d. Select all of the text in the Name text box and type a name for the 
entry. For the second steroid, type deoxycorticosteroneMS2.

e. Click Add to Library to display the Choose Library To Save To 
dialog box. Click OK to copy the next spectrum entry to the library 
ms2test. (The entry Text File in the Librarian window does not 
change.)

Figure 22. Librarian window, showing a steroid spectrum in the list of ms2test library entries 
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6. Copy and paste the library entry deoxycorticosteroneMS2 from the Hit 
List pane to the Spec List pane (see Figure 23).

a. Choose Window > Lib. Search in Library Browser to display the 
Library Search window.

b. Select steroids14 in the Spec List pane. Right-click this entry and 
select Library Search. Library Browser finds the entry 
deoxycorticosteroneMS2 and copies it to the Hit List pane. 

c. Select the Hit List entry deoxycorticosteroneMS2. Right-click this 
entry and choose Copy from the shortcut menu. 

d. Move the cursor to the Spec List pane and left click the mouse 
button to make the Spec List pane active.

e. Right-click to display the shortcut menu and choose Paste to paste 
the entry deoxycorticosteroneMS2 to the Spec List window. 

Figure 23. Library Browser panes, showing the results of a search from the Spec List paneL
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7. Choose Window > Librarian to display the Librarian window (see 
Figure 24).

Figure 24. Librarian window, showing the entry from the source Text File highlighted
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8. Highlight the entry from the source Text File and click the Delete From 
Library button in the toolbar to delete the entry (see Figure 25).

9. Click the Qual Browser button in the task bar at the bottom of the 
monitor screen to display the Qual Browser window.

10. Repeat Steps 2 through 9 (above) to append the third steroid entry, 
methyltestosteroneMS2, to the Spec List.

Figure 25. Librarian window, showing the entries from the source ms2test only
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11. Repeat Steps 2 through 8 (above) to append the fourth steroid entry, 
progesteroneMS2, to the Spec List. 

The Library Search window of the Library Browser should appear 
similar to Figure 26.

12. Close the windows, and return to the Xcalibur Home Page:

a. Choose File > Exit to close Library Browser and return to Qual 
Browser.

b. Choose File > Exit again to close the Qual Browser window and 
return to the Xcalibur Home Page.

Figure 26. Library Search window, showing the Compare Result pane containing the MS/MS spectra of 
four steroids
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Managing the NIST
Libraries

To add, delete, or move a library from the NIST libraries list, use the 
Xcalibur Library Manager dialog box – Manage Libraries page. This section 
shows you how to complete the following tasks in the Library Manager:

• Adding a Library

• Deleting a Library

• Copying a Library

To open the Xcalibur Library Manager

1. If the Xcalibur Home Page is not already open on the computer, open 
the home page by choosing Start > All Programs > Xcalibur > 
Xcalibur. Verify that the home page is in Roadmap view.

2. In the Xcalibur Home Page, choose Tools > Library Manager to open 
the Xcalibur Library Manager dialog box. The Library Manager opens 
on the Manage Libraries page by default (see Figure 27). 

Figure 27. Xcalibur Library Manager dialog box - Manage Libraries page
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Adding a Library To add a library to the NIST Libraries list, use the Add button. Either copy 
the library file to the local computer or link to the library at a remote 
location without copying files.

To add a library

1. In the Xcalibur Library Manager dialog box, click Add to open the Add 
Library dialog box (see Figure 28).

2. In the Add Library dialog box, type the path for the library file to add in 
the Source field or click Browse to bring up the Browse for Folder 
dialog box and find the desired file.

3. Select one of the two option buttons:

• Copy the library to the local computer

• Link to the library from either a remote location or computer. 

4. Click OK to add the desired library to the NIST Libraries list and 
return to the Xcalibur Library Manager dialog box.

5. If you have no more tasks to complete with the Library Manager, click 
Exit to close the Xcalibur Library Manager dialog box.

Figure 28. Add Library dialog box

Note  Because libraries can be large, you can often save time by 
selecting the Link option rather than the Copy option.
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Deleting a Library To delete a selected library in the NIST Libraries list, use the Delete 
button

1. In the Xcalibur Library Manager dialog box, select a library to delete by 
clicking the library name in the NIST Libraries list.

2. Click Delete. The system prompts you to confirm the deletion. To 
delete that library, click Yes.

3. If you have no more tasks to complete with the Library Manager, click 
Exit to close the Xcalibur Library Manager dialog box.

Copying a Library To copy a selected library to another directory on the computer or network, 
use the Archive button. 

To copy a library

1. In the Xcalibur Library Manager dialog box, select a library to copy by 
clicking the library name in the NIST Libraries list.

2. Click Archive to open the Archive Library dialog box (see Figure 29).

3. In the Archive Library dialog box, type the path for the copied library 
file in the Destination field or click Browse to bring up the Browse for 
Folder dialog box and find the desired location.

4. Click OK to copy the desired library to the remote location and return 
to the Xcalibur Library Manager dialog box.

5. If you have no more tasks to complete with the Library Manager, click 
Exit to close the Xcalibur Library Manager dialog box.

Figure 29. Archive Library dialog box
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Converting Libraries
to Another Format

To convert all or any portion of a library to another format, use the Xcalibur 
Library Manager dialog box – Convert Libraries page (see Figure 30). Also, 
use this page to copy a library to another location.

To convert a library from one format to another:

1. In the Xcalibur Library Manager, type the following information in the 
Source Library Details group box:

• Select the type of the source library, based on the file extension, 
from the Type drop-down menu.

• Type the path to the source library in the Library field or click 
Browse to open the Browse for Folder dialog box and find the 
desired file.

Figure 30. Xcalibur Library Manager dialog box - Convert Libraries page
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• To convert only certain entries from the source library, type the 
number range of the entries to convert in the Process Entries field. 
For example, to convert only entries #100 to #200, type 100-200 in 
the Process Entries field.

2. Enter the following information in the Target Library Details group 
box:

• Select the type of the target library, based on the file extension, from 
the Type drop-down menu.

• Type the path to the target library in the Library field or click 
Browse to open the Browse for Folder dialog box and find the 
desired folder.

• When you select ICIS/GCQ/ITS 40 or MassLab as the target 
library type, the Title field becomes active. Type the title for the 
converted library in this field.

3. Make the following choices in the Options group box, if desired: 

• Select either the Create/Replace option button or the Append 
option button. Create/Replace is selected by default.

• When you select NIST as the source library type, the Include 
Replicate Entries From The NIST Library in the Target Library 
check box becomes active. Click this check box to copy replicate 
entries.

• When you select the Include Replicate Entries check box, the 
Replicate library field is active. The default replicate library is 
C:\NIST02\MSSEARCH\REPLIB. To use a different replicate 
library, type the path to the desired library in the Replicate library 
field or click Browse to open the Browse for Folder dialog box and 
find the desired folder.

Note  When you select “NIST” as the target library type, the 
default target library is the library folder for Xcalibur: 
C:\NIST02\MSSEARCH\.
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4. Click Convert to begin the conversion process. The Conversion Status 
text box displays sequential chronological (top to bottom) messages such 
as:

Started the conversion on SEP 3, 1999 at 10:01, please wait
Finished the conversion on SEP 3, 1999 at 10:02
Converted 570 entries

5. If you have no more tasks to complete with the Library Manager, click 
Exit to close the Xcalibur Library Manager dialog box.

In this chapter, you did the following:

• Created a user library containing four MS/MS spectra

• Edited a library entry to include compound structure 

• Added, deleted, and copied libraries

• Converted a library from one format to another
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Chapter 3 Searching Libraries 

After you create a custom library of spectra, you can search it or other 
libraries. Set up libraries to search them automatically or search them 
manually from Qual Browser or Library Browser.

This chapter contains the following sections:

• Setting Up to Search Libraries Automatically

• Reprocessing Raw Files and Printing Reports

• Initiating a Library Search from Qual Browser

• Searching a Library by Using Library Browser

• Customizing the Library Browser Layout
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Setting Up to Search
Libraries

Automatically

To set up method files in Xcalibur that search libraries automatically:

• Use the Xcalibur Processing Setup window to create a processing 
method file (.pmd).

• Use the Sequence Setup window to reprocess data files in a sequence list 
(.sld) with the processing method that you created.

To set up for automatic searching, complete the following procedures:

• Specifying Search Parameters in the Qual View

• Specifying Report Options for Library Searches

• Specifying Raw Data Files in Sequence Setup

Specifying Search
Parameters in the Qual

View

To search libraries automatically, set up the Qual view in the Processing 
Setup window. For this example, use steroids data.

To specify parameters for a qualitative library search in the Qual view

1. From the Xcalibur Home Page, click the Processing Setup button. 

The Processing Setup window appears.

2. Open a raw data file in the Qual view:

a. Choose File > New to display the Identification page of the Quan
view. 

b. Click the Qual button to display the Qual view.

c. Choose File > Open Raw File to display the Open Raw File dialog
box. 

Note  If you need more information about setting up methods, refer to 
online Help.

Note  To use the Library Search Constraints page, you must have specific 
knowledge about the target compounds in the chromatogram. It is not 
always possible to use this knowledge to refine automated processing.
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d. Select the C:\Xcalibur\examples\data\steroids14.raw file and click 
Open to display the raw data (see Figure 31).

3. Confirm that the MS option is selected in the Type list of the Detector 
area and that ICIS is selected in the Peak Detect list.

4. Specify a scan filter on the Identification page:

a. Click the down arrow of the Filter combo box to display the scan 
filters in steroids14.raw.

b. Click one of the filters to select it. 

5. Click OK to accept changes to the Identification page.

Figure 31.  Processing Setup window, showing the Qual view

Note  For more information about the algorithms that Xcalibur uses 
to perform library searches, refer to the online Help.
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6. Click the Advanced button to display the ICIS Advanced Parameters 
dialog box (see Figure 32).

a. Confirm that the INCOS Noise option is selected in the Noise 
Method area.

b. Click OK to close the dialog box and return to the Processing Setup 
window.

7. Click OK to apply changes to the Identification page. 

Figure 32. ICIS Advanced Parameters dialog box, showing the option 
INCOS Noise
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8. Specify the name of the library to search:

a. Click the Library Search Options tab to display search type 
options. 

b. Click Search List to display the Search List dialog box.

a. Highlight MS2test in the Available Libraries list and click Add to 
move the library name to the Selected Libraries list.

b. Click OK to select MS2test and return to the Qual view of 
Processing Setup.

Leave the Qual view open and go to the next section, “Specifying Report 
Options for Library Searches” .

Note  

1. Xcalibur generates the Available Libraries list dynamically. 
Each time you open the Search List dialog box, Xcalibur lists 
the libraries available on the system at that time.

2. Libraries listed in the Selected Libraries list, on the other hand, 
might not exist on the system. They might have been selected 
on another system or deleted or renamed since the processing 
method was created.

Figure 33. Search List dialog box, showing the selected library 
MS2test
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Specifying Report Options
for Library Searches

To produce and print reports automatically, specify report options. This 
procedure continues from the previous section, “Specifying Search 
Parameters in the Qual View” on page 42.

Specify that you want to display the data in steroids14.raw in the format of 
a custom report template:

1. Click the Reports button on the View bar in the Processing Setup 
window, or choose View > Reports to display the Reports view (see 
Figure 34). 

Note  Refer to the manual Xcalibur Getting Productive: Designing and 
Generating Custom Reports with XReport for more information about how 
to create custom report templates using Microsoft Word.

Note  If the Apply Changes? dialog box appears, read the message  
and click Yes.

Figure 34.  Processing Setup window, showing the Reports view
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2. Click the Enable cell in the Sample Reports area to display a check box 
. Then, select  the check box to make Row 1 active (see Figure 35).

3. Specify the sample brackets in Row 1:

a. Click Yes in the Std column and clear the check box to exclude the 
bracket for standards from the report. 

b. Click Yes in the QC column and clear the check box to exclude the 
bracket for quality control samples.

c. Click Yes in the Other column and clear the check box.

Figure 35. Processing Setup window, showing the Reports view with Row 1 active
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4. Specify the name of a Report Template (.doc) in Row 1:

a. Double-click the Report Template Name cell to display the Browse 
For Sample Report Template dialog box. 

b. Scroll to select the C:\Xcalibur\Templates\CustLibrSearRept2.doc. 
file (see Figure 36).

c. Click Open to select the report template, and display the filename 
in the Report Template Name cell.

Figure 36. Browse For Sample Report Template dialog box
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5. Click OK to apply changes to the Reports view (see Figure 37).

Figure 37. Processing Setup window, showing the Reports view and a specified Report Template 
Name
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6. Save the processing method:

a. Choose File > Save As to display the File Summary Information 
dialog box (see Figure 38).

b. Type file summary information in the Description box and click 
OK to display the Save As dialog box.

Figure 38. File Summary Information dialog box
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c. Name the processing method: 
C:\Xcalibur\examples\methods\steroidsMS2.pmd (see Figure 39). 
(Save the processing method to the specified directory for ease of 
retrieval later.)

d. Click Save to save the method and return to the Reports view.

7. Choose File > Exit to close the Processing Setup window and return to 
the Xcalibur Home Page.

Go to the next section, “Specifying Raw Data Files in Sequence Setup” on 
page 52.

Figure 39. Save As dialog box, showing the processing method file 
steroidsMS2.pmd
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Specifying Raw Data Files
in Sequence Setup

To search libraries and print reports automatically, specify the raw files 
containing the data to process. This procedure continues from the previous 
section, “Specifying Report Options for Library Searches” on page 46.

Display the Sequence Setup window, and open the 
C:\Xcalibur\examples\methods\steroid.sld sequence list: 

1. Click the Sequence Setup button on the Xcalibur Home Page to 
display the Sequence Setup window.

2. Open a sequence list file into the Sequence Setup window:

a. Choose File > Open to display the Open dialog box.

b. Scroll to select the C:\Xcalibur\examples\methods\steroid.sld 
sequence file and double-click to display the list of samples (see 
Figure 40).

3. Specify to include only two samples in the list:

a. Highlight Rows 1 through 10 and choose Edit > Delete Row to 
leave three samples remaining in the sequence. Xcalibur displays a 
message box to confirm the Delete Row command. Click Yes.

Figure 40. Sequence Setup window, showing a list of two files contained in steroid.sld
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b. Highlight Row 3 and choose Edit > Delete Row to leave two 
samples remaining in the sequence. Xcalibur displays a message box 
to confirm the Delete Row command. Click Yes (see Figure 41).

4. To view the Sample Type column, click the left side of the horizontal 
scroll bar at the bottom of the workspace. Double-click the Row 1 cell 
in the Sample Type column to display a drop-down list. Then, scroll up 
to select Unknown.

5. Expand the width of the Path column to confirm that the directory is 
the one in which the raw files are stored. For example, raw files 
containing steroids data are found in C:\Xcalibur\examples\data.

6. Double-click the Row 1 cell in the Processing Method column to 
display the Select Processing Method dialog box. Browse to select the 
C:\Xcalibur\examples\methods\steroidsMS2.pmd processing method 
(see Figure 42).

.

7. Repeat Steps 4 and 5 for the second row of the sequence. Step 6 is 
repeated automatically for subsequent rows.

Figure 41. Sequence Setup window, showing a list of two files contained in steroid.sld

Note  Use Sequence Setup to create a sequential list containing a 
variety of sample types or brackets. However, for qualitative 
analysis the type is usually unknown.

Figure 42. Sequence Setup window, showing the edited list of two files contained in steroid.sld
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8. Save the sequence list file:

a. Choose File > Save As to display the File Summary Information 
dialog box. Type practice in the Description box and click OK.

b. Type steroidPractice in the File Name box to name the sequence.

c. Click Save to save the sequence list, and return to the Sequence 
Setup window.

You are now ready to reprocess the Xcalibur sequence and print custom 
reports automatically. Go on to the next section, “Reprocessing Raw Files 
and Printing Reports” .
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Reprocessing Raw
Files and Printing

Reports

To reprocess raw data and print reports automatically, use Sequence Setup. 
This procedure continues from the previous section, “Specifying Raw Data 
Files in Sequence Setup” on page 52.

To reprocess a list of raw files and print library search reports 

1. In Sequence Setup, click and hold on the row number in Row 1 and 
drag the cursor to Row 2 to select the rows in the current sequence to 
reprocess. Xcalibur highlights the selected rows. 

2. Choose Actions > Batch Reprocess or click the Batch Reprocess 
button on the toolbar to display the Batch Reprocess Setup dialog box. 

3. Confirm that the Process Rows box reads 1-2. If it does not, 
double-click the box and type 1-2. 

4. Select  only the following check boxes:

• Qual

• Peak Detection & Integration

• Library Search

• Reports

• Print Sample Reports 

• Replace Sample Info
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The dialog box should look like Figure 43.

5. Click OK to initiate batch reprocessing of the selected samples. If 
Xcalibur displays a message box, as shown in Figure 44, click Yes.

Figure 43. Batch Reprocess Setup dialog box, showing selected options

Figure 44. Message box, asking to save changes to 
the sequence list
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6. Click the steriods14 - Proc button in the Task bar to display the 
Processing Status window (see Figure 45). 

Two beeps signal the end of the batch reprocessing.

7. Go to the printer to get printed reports (one for each sample). See that 
they resemble those shown in Appendix A, “Example Reports”.

8. Choose View > Roadmap View to close Sequence Setup and display the 
Roadmap view.

Figure 45. Processing Status window, showing two samples in the queue
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Initiating a Library
Search from Qual

Browser

To perform a library search from the Qual Browser window:

1. Click the Qual Browser button on the Xcalibur Home Page to display 
the Qual Browser window.

2. Open a raw file that contains steroids data:

a. Choose File > Open or click the Open button in the toolbar to 
display the Open Raw File dialog box.

b. Browse to the Xcalibur\examples\data\steroids14.raw file and click 
Open.

3. Refer to the section “Viewing a Spectrum in Qual Browser” on page 10 
and follow the procedure (see Figure 46).

Figure 46. Qual Browser window, showing the following views (clockwise from lower left): Scan
Filter view, (filtered) Chromatogram view, (averaged) Spectrum view, (unfiltered)
Chromatogram view
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4. Select one or more libraries to search:

a. Right-click the Spectrum view (upper right) to display the shortcut 
menu. 

b. Choose Library > Options from the shortcut menu to display the 
Search Properties dialog box (see Figure 47).

c. Confirm that the MS2test and nistdemo libraries are listed in the 
Selected Libraries list.

d. Click OK to save the settings, close the dialog box and return to the 
Qual Browser window.

Figure 47. Search Properties dialog box, showing selected libraries 
MS2test and nistdemo
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5. Initiate the library search:

a. Right-click the Spectrum view (upper right) to display a shortcut
menu. 

b. Choose Library > Search from the shortcut menu to submit the 
spectrum to a library search. Xcalibur displays library spectra that 
match the spectrum (matches) in a four-pane Library Search Results 
view (see Figure 48). 

The interactive cells of the Library Search Results view show the 
following library search results, displayed clockwise from the upper left 
quadrant: 

• Hits list

• Molecular structure, including formula, molecular weight, name, 
and library index number

Figure 48. Qual Browser window, showing the Library Search Results view cascaded with the Raw 
Data view. Refer to the text above for a description of the contents of each cell.
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• Difference spectrum (Raw Data minus Library Entry)

• Peaks above the X-axis are relatively more intense in the spectrum 
than in the library entry. 

• Peaks below the X-axis are relatively more intense in the library 
entry than in the sample spectrum.

• Comparison of the sample spectrum and the library entry

6. Print the results of the search:

a. Choose File > Print Preview to display the Print dialog box (see 
Figure 49).

Figure 49. Print dialog box

b. Confirm that the following two options are selected:

• All Cells In The Selected Window

• One Page

c. Click OK to close the dialog box, and preview the results.

d. Click Print to display the Print dialog box again and click OK. 

e. Click OK in the second Print dialog box to print the results. Refer 
to Appendix A, “Example Reports” for an example of library 
search results initiated from Qual Browser.

7. Close  the Library Search Results view, and reveal the Qual Browser 
window. 

Leave the Qual Browser window open and go to the next section, 
“Searching a Library by Using Library Browser” .
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Searching a Library
by Using Library

Browser

To search a library, use the Library Browser window. This procedure 
continues from the previous section, “Initiating a Library Search from Qual 
Browser” on page 58.

To perform a library search on a spectrum exported from Qual Browser 

1. Confirm that the pin in the Spectrum view (upper right) in the Qual 
Browser window is active.

2. Right-click the Spectrum view to display the shortcut menu.

3. Choose Library > Export to Library Browser to open the Library 
Browser windows automatically. 

When you export a spectrum to Library Browser, Xcalibur 
automatically does the following:

• Copies information about the exported spectrum into the 
C:\Xcalibur\Libspecs directory. Xcalibur gives the file an extension 
of .msd and truncates the filename to the first eight characters of the 
original filename.

• Creates an index file containing details about the exported spectrum

When Library Browser opens, Xcalibur automatically does the 
following:

• Picks up the index file

• Locates the exported .msd spectrum files and lists them in the Spec 
List pane

Note  To display data files in Library Browser, export them from 
Qual Browser. You can export a spectrum into Library Browser 
from Qual Browser after opening a raw file (.raw) or a result file 
(.rst) in Qual Browser
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4. Define search parameters in Library Browser:

a. Choose Tools > Library Search Options to display the Library 
Search Property dialog box (see Figure 50).

Figure 50. Library Search Property dialog box 
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b. Click the Libraries tab to display the Available Libs and the 
Included Libs libraries (see Figure 51). Use this dialog box to specify 
which libraries to search and the search order. 

• To add a library to the search list, select its name in the Available 
Libs list and click Add.

• To exclude a library from the search list, select its name in the 
Included Libs list and click Exclude. 

In this example, include both MS2test and nistdemo.

c. Click the Search tab and observe the Automation check box in the 
Other Options area (Figure 50 on page 63). 

• If the check box is not checked, go to Step 4d.

• If the check box is checked for Automation, go to Step 4e.

Figure 51. Libraries Search Property dialog box, showing the included 
libraries MS2test and nistdemo
64 Xcalibur: Getting Productive with Libraries Thermo Electron Corporation



 3 Searching Libraries
Searching a Library by Using Library Browser
d. Click the Automation tab to display the Automation dialog box 
(see Figure 52). Select the Automatic Search On check box. 

e. Click OK to save the parameters, close the dialog box, and return to 
the Library Browser windows. (The option to search automatically 
is active for the next time you open the Library Browser windows.)

Figure 52. Automation page, showing option to search libraries 
automatically when exporting spectra to Library Browser
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5. Double-click the entry in the Spec List pane to begin a library search. 
The interactive panes of Library Browser change to display the results of 
the search (see Figure 53).

• Hit List History drop-down list shows the results of the search.
• Hit List pane contains a list of spectral results.
• Structures panes (tab) display the chemical structure of the compound 

associated with the highlighted entry.
• Text panes display compound names, a mass/intensity list, and a scan 

filter of the highlighted entry. (Refer to the online Help in Library 
Browser for more information.)

• Plot panes display a single mass spectrum of a selected entry.
• Compare pane displays the difference between two spectra and presents 

them in various ways.

Figure 53. Library Browser default window, showing the library search results on the raw spectrum that you 
exported from Qual Browser
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6. Right-click HydrocortisoneMS2 in the Hit List pane to copy it to the first 
position in the Spec List pane (see Figure 54).

7. Click Print in the button bar to print the search results. Refer to 
Appendix A, “Example Reports” for an example of library search 
results initiated from Library Browser.

Leave the windows open and go to the next section, “Customizing the 
Library Browser Layout” on page 68.

Figure 54. Library Browser default window, showing file copying from Hit List to Spec List panes
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Customizing the
Library Browser

Layout

To customize the layout of the Library Browser windows or customize the 
appearance of each of the windows, refer to the online Help in Library 
Browser.

In this chapter, you did the following:

• Set up a processing method in Processing Setup to search libraries 
automatically

• Reprocessed a sequence of data files in Sequence Setup

• Printed library search results of raw data automatically

• Used Qual Browser and Library Browser to search libraries

• Printed library search results 
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Appendix A Example Reports

This appendix contains examples of results you can obtain by using Xcalibur 
Library Browser software and the following sections:

• Reports from a Library Search Using Sequence Setup

• Report from a Library Search Using Qual Browser

• Report from a Library Search Using Library Browser
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Reports from a Library
Search Using

Sequence Setup

This section includes examples of library search reports that Xcalibur prints 
automatically from Sequence Setup.
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Report from a Library
Search Using Qual

Browser

This section includes an example report of a library search that you can 
print from Qual Browser.
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Report from a Library
Search Using Library

Browser

This section includes an example report of a library search that you can 
print from Library Browser.
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