For Research Use Only. Not for Use in Diagnostic Procedures.

**Trademarks**

Affymetrix®, GeneChip®, HuSNP®, GenFlex®, Flying Objective™, CustomExpress®, CustomSeq®, NetAffx™, Tools To Take You As Far As Your Vision®, The Way Ahead™, Powered by Affymetrix™, and GeneChip-compatible™ are trademarks of Affymetrix, Inc.

All other trademarks are the property of their respective owners.

**Limited License**

Subject to the Affymetrix terms and conditions that govern your use of Affymetrix products, Affymetrix grants you a non-exclusive, non-transferable, non-sublicensable license to use this Affymetrix product only in accordance with the manual and written instructions provided by Affymetrix. You understand and agree that except as expressly set forth in the Affymetrix terms and conditions, that no right or license to any patent or other intellectual property owned or licensable by Affymetrix is conveyed or implied by this Affymetrix product. In particular, no right or license is conveyed or implied to use this Affymetrix product in combination with a product not provided, licensed or specifically recommended by Affymetrix for such use.

**Copyright**

©2006-2007 Affymetrix, Inc. All Rights Reserved
Contents

Chapter 1 The GeneChip® HT Array Plate Scanner .................5
  Introduction ................................................. 5
  Intended Use ............................................. 6
  About This Manual ...................................... 7
  User Documentation .................................... 7

  Safety ......................................................... 8
  Safe Operation ......................................... 8
  Hazards ..................................................... 9
  Laser Safety ............................................. 10
  When to Contact Affymetrix ............................ 11

  GeneChip® HT Array Plate Scanner Specifications ........ 12

  Technical Support Contact Information ................. 13

  Regulatory and Conformity .............................. 14
  Regulatory Compliance .................................. 14
  CE Mark Declaration of Conformity .................... 15

  China RoHS Restriction of Hazardous Substances Compliance 16

  SJ/T11364-2006 电子信息产品污染控制标识要求 .......... 18

Chapter 2 Setup and Operation ................................. 21
  Introduction ................................................. 21
  Indicator Lights ......................................... 22
  On/Off Switch ............................................ 22
  Stage Door ................................................ 23
  User Interface .......................................... 23
  Sequence of Events .................................... 23

  The Software Application ............................... 26
  Desktop Icon ............................................. 26
  Quick Reference Guide ................................ 26
  Checking Hard Disk Space .............................. 27

  Setting Up the HT Array Plate Scanner ................. 28
Installing the Scanner ......................................................... 28
Uninterruptible Power Supply ............................................ 30
Powering the Scanner and Launching the HT Scanner Control Software ............. 31

Main Command and Control Window ...................................... 32
Main Control Window components ........................................... 32

Scanning HT Array Plates .................................................. 35
Manually Entering a Barcode .................................................. 43

Shutting Down ............................................................... 45

Chapter 3 Maintenance and Troubleshooting ....................... 47
Cleaning and Maintenance ....................................................... 47
  Monthly ............................................................................ 47
  Every Six Months .............................................................. 47
Troubleshooting ................................................................. 47
  Power Problems ............................................................... 48
  Error Messages ............................................................... 48

Chapter 4 HT Image Reader ............................................... 49
Introduction ........................................................................... 49
HT Image Reader Application Layout ...................................... 49
Getting Started ................................................................. 50
  Analysis Options .............................................................. 50
  E-mail Alert Options .......................................................... 50
  Publish Database .............................................................. 51
  GCOS Mode ..................................................................... 51
  Invoking An Analysis ........................................................ 51
  Rescanning An HT Array Plate ........................................... 51
Analysis Options ................................................................. 51
  Auto Invocation Parameters ................................................. 51
  Scanner Information ........................................................ 52
  Multi-Scan Parameters ....................................................... 52
  Analysis Parameters ........................................................ 52
  Analysis Results Checks .................................................... 52
  Publish Parameters ........................................................ 53
  Results Check Options ..................................................... 54
E-mail Alerts ................................................................. 57
Invoking an Analysis .................................................. 58
Menu Commands ......................................................... 60

Workflow Status Messages ................................. 60
Menu Commands ....................................................... 61
Query Messages ...................................................... 61
Opening an Image File .............................................. 62
Sub Image Indexing ..................................................... 63
Image Display ........................................................ 64
Image Settings ......................................................... 66
Well to Experiment Mapping ..................................... 67
Creating the Mapping ............................................... 67
Viewing the Mapping ............................................... 68

Advanced Tools ...................................................... 70
Rename Barcode ....................................................... 70
Image Manipulation .................................................. 71
Deleting Acquisitions ............................................... 71

Menu Commands .................................................... 73
Toolbar Buttons ..................................................... 74

Chapter 5  HT Image Reader Appendix ......................... 75
Introduction .......................................................... 75

Appendix I – GCOS Objects ................................. 75
GCOS Experiment .................................................... 75
GCOS Sample ........................................................ 76

Appendix II – Data Access ................................. 77
Files SDK ............................................................ 77
GCOS SDK .......................................................... 77
AADM Schema and SDK ......................................... 77
Expression Exporter SDK ......................................... 77

Appendix III – FAQ ............................................... 78

Appendix IV – Workflow ........................................ 85
Workflow .............................................................. 85
Chapter 1

THE GENECHIP® HT ARRAY PLATE SCANNER

Introduction

Welcome to the Affymetrix GeneChip® HT Array Plate Scanner. Affymetrix has developed the HT Array Plate Scanner to deliver a complete, flexible solution for increased productivity and standardization. The HT Array Plate Scanner (Figure 1.1) can scan a 96-well or a 24-well GeneChip HT array plate (Figure 1.2) to provide you with an integrated system that delivers the most accurate and reproducible data possible.

Figure 1.1
The GeneChip® HT Array Plate Scanner
The HT Array Plate Scanner is used as part of the gene expression analysis system using microarrays manufactured by Affymetrix. The target sample for scanning must already have been hybridized and stained using Affymetrix protocols. When illuminated by the scanner LEDs, the stain fluoresces according to how well the gene has been expressed. The scanner scans and records an image of the microarrays and then moves the HT array plate out.

**Intended Use**

Designed with multiple capabilities, this scanner also provides scalable and flexible options for meeting both your current and future research requirements. The GeneChip HT Array Plate Scanner has been designed and optimized for use with the GeneChip HT array plate system.

**WARNING**

Use the scanner only as instructed in this user guide. Do not attempt to service the instrument. Only qualified service technicians can open and service the scanner. There are no customer serviceable parts. Removing the case exposes the customer to laser and electrical shock hazards.
Treat the HT Array Plate Scanner as you would any piece of high-magnification optical equipment:

- Place the scanner on a solid, secure laboratory bench or steel trussed table.
- While scanning, avoid dropping heavy objects onto the bench near the scanner.
- While scanning, avoid striking the scanner cabinet.
- Avoid placing the scanner close to heavy, vibrating machinery, such as compressors.

About This Manual

This manual was written for operators who run the Affymetrix GeneChip HT Array Plate Scanner. It includes information on the following:

- Safety and hazards
- Regular operation of the scanner
- Controls and status indicators
- User interface
- Startup/shutdown procedures
- Troubleshooting and preventative maintenance

User Documentation

The operation of the HT Array Plate Scanner requires familiarity with other user documentation. Those manuals that are relevant for you will depend on your system configuration. For the HT array system configuration, refer to the following documents.

1. HT Array Plate Scanner Site Preparation Guide (P/N 08-0257).
2. GCOS User’s Guide (P/N 701439): if you are using Affymetrix GeneChip® analysis software, you should be familiar with Affymetrix’ GeneChip® Operating System in order to interpret the assay results.
Safety

This section deals with safety issues and hazards concerning the scanner present during regular operation. To ensure safe operation of the GeneChip HT Array Plate Scanner, read this section completely before operating the instrument.

CAUTION

The power supply cord is used as the main disconnect device. Ensure that the socket outlet is located and installed near the equipment and is easily accessible.

ATTENTION

Le cordon d’alimentation est utilisé comme interrupteur général. La prise de courant doit être située ou installée à proximité du matériel et être facile d’accès.

ACHTUNG

Zur sicheren Trennung des Gerätes vom Netz ist der Netzstecker zu ziehen. Vergewissern Sie sich, daß die Steckdose leicht zugänglich ist.

Safe Operation

- Do not attempt to service this scanner. Any attempt at unauthorized service may result in injury or damage the instrument and/or void the warranty.
- Do not place the scanner on an unstable cart, stand, or table. Failure to properly support the instrument may cause serious damage or injury and may void the warranty.
- The instrument must be surrounded by adequate airspace. Slots and openings in the instrument and the electronics compartment covers are for ventilation. Do not block or cover them.
- Never push an object into the instrument ventilation slots; equipment damage or injury may result. Do not set liquids on top of the instrument.
- The instrument has an AC receptacle with a safety ground appropriate for the country of destination. The plug is designed to connect only to a 3-prong ground receptacle. This safety feature should not be compromised in any way. If the instrument AC plug does not mate with the available power source receptacle, consult a licensed electrician to install one that does.
- Do not open the scanner cabinet. This contains electrical hazards.
HAZARDS

The following sections and Table 1.1 describe possible hazards present in this scanner.

General Hazards

CAUTION

If you use the GeneChip HT Array Plate Scanner in a manner not specified in this user’s guide, you may impair the protection provided by the equipment.

<table>
<thead>
<tr>
<th>Hazard</th>
<th>Present?</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Chemical</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Control</td>
<td>No</td>
<td>Control software</td>
</tr>
<tr>
<td>Electrical</td>
<td>Yes</td>
<td>100-240V power</td>
</tr>
<tr>
<td>Ergonomic</td>
<td>Yes</td>
<td>User interface</td>
</tr>
<tr>
<td>Gas</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Mechanical</td>
<td>Yes, Yes</td>
<td>scanning stage, scanner weight (heavy instrument)</td>
</tr>
<tr>
<td>Laser</td>
<td>Yes, Yes</td>
<td>if you remove the scanner enclosure.</td>
</tr>
<tr>
<td>Noise</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Pneumatic</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Radiation</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Temperature</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Ultrasonic</td>
<td>No</td>
<td></td>
</tr>
<tr>
<td>Vibration</td>
<td>No</td>
<td></td>
</tr>
</tbody>
</table>

Mechanical Hazards

The scanner has a moving stage that ejects from its left side. Take care to provide adequate open bench space on the left side of the scanner. Avoid placing hands or face near the load tray when loading or ejecting plates.

Do not wear loose clothing while working with the machine. Tie back long hair. Remove any jewelry that hangs down.
Electrical Hazards

- Do not use the scanner if you see damaged or frayed electrical cords. Tag and report them as unsafe.

Do not place any liquids or containers holding liquids on or near electrical systems.

Ergonomic Hazards

The scanner has an user interface that may pose ergonomic issues. To avoid fatigue or muscle pain, follow basic precautions including the following:

- Read, understand, and follow your workplace ergonomic recommendations.
- Move user interface so that you can use it comfortably.
- Take short, regular breaks away from the scanner.
- Make sure the area is well-lit and you are able to see the information on the screen clearly.

Laser Safety

Always take note of laser safety labels; they indicate areas where exposure to laser beams may be hazardous.

When used according to the instructions in this manual and when all covers are in place, the GeneChip HT Array Plate Scanner is classified as a Class 1 Laser Device per 21 CFR 1040 and IEC/EN 60825-1.

When to Contact Affymetrix

Under any of the following conditions, unplug the instrument from the power source and contact technical Support:

• When the power cord is damaged or frayed.
• If any liquid, such as scan buffer, has been spilled into the instrument.
• If the instrument has been penetrated by water.
• If, after service or calibration, the instrument does not perform in accordance with the capabilities stated in the specifications.
• If the instrument has been dropped or otherwise damaged.
• If the instrument must be returned for repair, call Affymetrix Technical Support.
GeneChip® HT Array Plate Scanner Specifications

Table 1.2 lists the important instrument specifications.

<table>
<thead>
<tr>
<th>Item</th>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Weight</td>
<td>Shipping</td>
<td>~216 pounds (98 kg)</td>
</tr>
<tr>
<td></td>
<td>Free-standing</td>
<td>~145 lbs (66 kg)</td>
</tr>
<tr>
<td>Dimensions</td>
<td>Width</td>
<td>~16 in.</td>
</tr>
<tr>
<td></td>
<td>Depth</td>
<td>~29 in.</td>
</tr>
<tr>
<td></td>
<td>Height</td>
<td>~26 in.</td>
</tr>
<tr>
<td>Power</td>
<td>Voltage</td>
<td>100 - 240 V</td>
</tr>
<tr>
<td></td>
<td>Current</td>
<td>2.8 - 1.2 A</td>
</tr>
<tr>
<td></td>
<td>Line Frequency.</td>
<td>50 - 60 Hz</td>
</tr>
<tr>
<td>Working Environment</td>
<td>Temperature</td>
<td>59°F-85°F (15°C-30°C)</td>
</tr>
<tr>
<td></td>
<td>Humidity</td>
<td>10-90% Non-condensing</td>
</tr>
<tr>
<td></td>
<td>Clearance</td>
<td>2 in. (5 cm) in rear</td>
</tr>
<tr>
<td></td>
<td></td>
<td>12 in. (30.5 cm) on left side</td>
</tr>
<tr>
<td></td>
<td>Pollution Degree</td>
<td>2</td>
</tr>
<tr>
<td></td>
<td>Installation Category</td>
<td>II</td>
</tr>
<tr>
<td></td>
<td>Altitude</td>
<td>&lt;2000m</td>
</tr>
<tr>
<td>Electrical Supply</td>
<td>Provide voltage, frequency or power rating per unit label.</td>
<td></td>
</tr>
<tr>
<td>Main Supply Voltage</td>
<td>Fluctuations</td>
<td>Are not to exceed ±10% of the nominal supply voltage</td>
</tr>
</tbody>
</table>
Technical Support Contact Information

Affymetrix provides technical support to all licensed users via phone or E-mail. Contact information is listed below.

**Affymetrix, Inc.**
3420 Central Expressway
Santa Clara, CA 95051 USA
Tel: 1-888-362-2447 (1-888-DNA-CHIP)
Fax: 1-408-731-5441

support@affymetrix.com

**Affymetrix UK Ltd.**
Voyager, Mercury Park,
Wycombe Lane, Wooburn Green,
High Wycombe HP10 0HH
United Kingdom

UK and Others Tel: +44 (0) 1628 552550
France Tel: 08000919505
Germany Tel: 01803001334
Fax: +44 (0) 1628 552585

sales@affymetrix.com
support@affymetrix.com

**Affymetrix Japan, K. K.**
Mita NN Bldg
16 Floor, 4-1-23 Shiba,
Minato-ku, Tokyo 108-0014
Japan

Tel: (03) 5730-8200
Fax: (03) 5730-8201

[www.affymetrix.com](http://www.affymetrix.com)
Regulatory and Conformity

Regulatory Compliance

We declare under sole responsibility that the Affymetrix® GeneChip® HT Array Plate Scanner and associated Workstation with software, is manufactured in the United States of America, with U.S. and Non-U.S. components.

This device complies with Part 15 of FCC Rules. Operation is subject to the following two conditions: (1) This device may not cause harmful interference, and (2) This device must accept any interference received, including interference that may cause undesired operation.

This Class A digital apparatus meets all requirements of the Canadian Interference-Causing Equipment Regulation.

Cet appareil numérique de la classe A respecte toutes les exigences du Règlement sur le matériel brouilleur du Canada.

This device has been approved by the following regulatory agencies (Table 1.3).
Table 1.3
Regulatory Approval

<table>
<thead>
<tr>
<th>Regulatory Agency</th>
<th>Certification</th>
</tr>
</thead>
</table>
| CE | IEC 61010-1  
CSA C22.1010.1:1992 (Canada)  
UL 61010A-1:2002 (USA)  
EN 61010-1:2001 (EU)  
Mechanical Safety: EN 1050:1996  
| | Compliant with directive 2002/96/EC (WEEE)  
371123740 (WEEE German Registration)  
WEEE Registration–France |
| | Class I Laser Device  

CE Mark Declaration of Conformity

The GeneChip® HT Array Plate Scanner conforms with the relevant provisions of the following standard(s) and/or other normative document(s):

EU EMC Directive 89/336/EEC:

**EN61326-1:1997+A2:2001**  
Equipment for Measurement Control and Laboratory Use

**EN55011:1998+A2:2002**  
Limits and methods of measurements of radio disturbance characteristics of industrial, scientific and medical (ISM) radio frequency equipment

**ICES-003 and FCC Part 15**

**EN 61000-3-2:2000+A1:2001**  
Limits for harmonic current emissions (equipment input < 16A per phase)

**EN 61000-3-3:1995+A1:2001**  
Limitation of voltage fluctuations and flicker in low voltage supply systems for equipment with rated current < 16A

**EN 61000-4-2:1995**  
Electrostatic discharge immunity
Manufacturers of Electronic Information products (EIPs) that are sold to the People's Republic of China, are required to provide information about lead, cadmium, mercury, hexavalent chromium, polybrominated biphenyls and polybrominated diphenyl ethers contained within.

In accordance with the Chinese RoHS (Restriction of Hazardous Substances)\(^1\), Table 1.4 contains information identifying the specific hazardous material(s) and the components/parts in which they are found.

---

\(^1\)电子信息产品污染控制标识要求 (Marking for Control of Pollution Caused by Electronic Information Products) SJ/T11364-2006
Table 1.4
Table Containing Names and Contents of Toxic or Hazardous Materials*
Instrument: Affymetrix GeneChip HT Array Plate Scanner

<table>
<thead>
<tr>
<th>Component/Part Categories</th>
<th>Lead (Pb)</th>
<th>Mercury (Hg)</th>
<th>Cadmium (Cd)</th>
<th>Hexavalent Chromium (Cr 6)</th>
<th>Polybrominated Biphenyls (PBBs)</th>
<th>Polybrominated Diphenyl Ethers (PBDEs)</th>
</tr>
</thead>
<tbody>
<tr>
<td>Printed Circuit Boards</td>
<td>X</td>
<td>0</td>
<td>X</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Rubber &amp; Plastic Parts</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Electrical Components</td>
<td>X</td>
<td>0</td>
<td>X</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Internal Metal Parts</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>External Metal Parts</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Labels</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Packaging/Shipping Materials</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Internal Lasers, Optics &amp; Sensors</td>
<td>X</td>
<td>0</td>
<td>X</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Adhesives</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Internal Power Supplies</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
<tr>
<td>Motors and Pumps</td>
<td>O</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
<td>0</td>
</tr>
</tbody>
</table>

*X* = Indicates that the toxic or hazardous substance contained is above the limit of 1000 ppm for lead and above 100 ppm for cadmium

O = Indicates that the toxic or hazardous substance contained is below the limit of 1000 ppm for lead, mercury, hexavalent chromium, polybrominated biphenyls and polybrominated diphenyl ethers; and below 100 ppm for cadmium.
目前许多电子信息产品由于功能、性能或生产技术的需要，仍含有大量如铅（Pb）、汞（Hg）、镉（Cd）、六价铬（Cr（VI））、多溴联苯（PBB）和多溴二苯醚（PBDE）等有毒有害物质或元素。这些含有毒有害物质或元素的电子信息产品在废弃之后，如处置不当，不仅会对环境造成污染，也会造成资源的浪费。因此，为了达到节约资源、保护环境的目的，以有毒有害物质或元素的减量化、替代为主要任务的电子信息产品污染控制工作已经提到政府主管部门的议事日程。为此，信息产业部等七部委以“从源头抓起，立法先行”的思路和原则，制定了《电子信息产品污染控制管理办法》（信息产业部39号部长令，简称《管理办法》），以立法的形式，推动电子信息产品污染控制工作，旨在从电子信息产品的研发、设计、生产、销售、进口等环节限制或禁止使用上述六种有毒有害物质或元素。

为了进一步落实《管理办法》并达到限制有毒有害物质或元素在电子信息产品中使用的目标，必须有配套使用的统一的标识方法标准。因此，为了配合中华人民共和国《管理办法》的实施，同时也为中华人民共和国信息产业界对六种有毒有害物质或元素铅（Pb）、汞（Hg）、镉（Cd）、六价铬（Cr（VI））、多溴联苯（PBB）和多溴二苯醚（PBDE）的测试提供一个统一的标识方法，特制定本标准（表Table 1.5）。

### Table 1.5
有毒有害物质或元素名称及含量

<table>
<thead>
<tr>
<th>部件名称</th>
<th>铅（Pb）</th>
<th>汞（Hg）</th>
<th>镉（Cd）</th>
<th>六价铬（Cr（VI））</th>
<th>多溴联苯（PBB）</th>
<th>多溴二苯醚（PBDE）</th>
</tr>
</thead>
<tbody>
<tr>
<td>印制电路板</td>
<td>X</td>
<td>O</td>
<td>X</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>橡胶和塑料元件</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>电子元件</td>
<td>X</td>
<td>O</td>
<td>X</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>内部金属零件</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>外部金属零件</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>标签</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>组装/装货资料</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>内部激光、光学器件和传感器</td>
<td>X</td>
<td>O</td>
<td>X</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
</tbody>
</table>
### Table 1.5 (Continued)
有毒有害物质或元素名称及含量

**仪器**: Affymetrix GeneChip HT Array Plate Scanner

<table>
<thead>
<tr>
<th>部件名称</th>
<th>铅 (Pb)</th>
<th>汞 (Hg)</th>
<th>镉 (Cd)</th>
<th>六价铬 [Cr (VI)]</th>
<th>多溴联苯 (PBB)</th>
<th>多溴二苯醚 (PBDE)</th>
</tr>
</thead>
<tbody>
<tr>
<td>胶粘剂</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>内部电源</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
<tr>
<td>马达和唧筒</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
<td>O</td>
</tr>
</tbody>
</table>

*○*: 表示该有毒有害物质在该部件所有均质材料中的含量均在 1000 ppm 铅 (Pb) 汞 (Hg), 六价铬 [Cr (VI)], 多溴联苯 (PBB), 多溴二苯醚 (PBDE), 100 ppm 镉 (Cd) 的标准规定的限量要求以下。

**X**: 表示该有毒有害物质至少在该部件的某一均质材料中的含量超出 1000 ppm 铅 (Pb) 100 ppm 镉 (Cd) 的标准规定的限量要求。

电子信息产品污染控制标识要求 (Marking for Control of Pollution Caused by Electronic Information Products) SJ/T 11364–2006
Introduction

This chapter details the various parts of the HT Plate Array scanner, the software user interface and how to use the scanner to process array plates.

Figure 2.1
Lights and Button of the HT Scanner
Indicator Lights

Two lights on the bottom front left corner indicate the scanner’s current status (Figure 2.1):

- When the green light is lit, the scanner is functioning normally.
- When the yellow light is lit, the scanner is in a warm up or standby state.

On/Off Switch

The ON/OFF (I/O) switch is located at the bottom front center corner of the instrument.

IMPORTANT

If you turn on the scanner using the front I/O button, you must also use this button to turn off the scanner. The software will not turn the scanner off if you have used this I/O button. Conversely, if you used the application GUI to turn on the scanner, do not press the I/O button to turn off the scanner. The application will automatically turn it off.
STAGE DOOR

The stage door is located on the left side of the instrument. During the scanning run, the stage door opens to receive or expel the plate array (Figure 2.2).

User Interface

The user interface consists of a separate PC, keyboard, mouse, and monitor connected to the scanner through its rear utility panel. The user interface allows you to run and control the actions of the scanner.

The user interface provides a GUI application which you use to run and control the scanner. The GUI includes images of the microarrays and fiducials as seen by the optics assembly, icons representing the HT array plates and microarrays and showing the run’s progress, and buttons and other commands that the user can click on or type in to control the process.

Sequence of Events

The scanner goes through the following events in scanning a plate.
1. The scanner’s stage extends out of the scanner through a door on the left side.
2. You place a HT array plate onto the stage.
3. The tip-tilt assembly moves to a handoff location, and the stage retracts, moving the scan tray into the scanner and in between the tip-tilt assembly’s two plates.
4. The tip-tilt assembly moves upward to pick the scan tray from the stage.
5. The tip-tilt assembly moves over the optics assembly so that the first HT array plate to be scanned is above the camera.
6. The tip-tilt assembly moves so the camera can focus on the fiducials for the HT array plate, using the amber LED’s light. There are two L-shaped and two square fiducials, one at each HT array plate’s corner for a total of four. The computer then calculates how to adjust the tip-tilt assembly so that the fiducials are all level with respect to the camera. The three tilt motors on the tip-tilt assembly then flatten the HT array plate with respect to the camera (Figure 2.3).

7. The tip-tilt assembly moves so the camera can scan the first subarray to be scanned, using the cyan LED’s light. The camera captures an image of the subarray with the DNA fluorescing and saves it on the computer. This is repeated until all subarrays are scanned on the HT array plate.
8. The tip-tilt assembly moves to the stage and lowers the scanned HT array plate and scan tray onto the stage's tray.

9. The stage extends to move the HT array plate and scan tray out of the scanner.

10. Remove the scanned HT array plate and tray and commands the stage to retract.
The Software Application

This section describes the scanner’s software application that you use to start, stop, and control the scanner.

Desktop Icon

Once the scanner has started up, the application that controls the instrument can be started by clicking the GeneChip HT Array Plate Scanner icon on the desktop.

Quick Reference Guide

Table 2.1 displays a quick look at how to use the scanner.

Table 2.1
Quick Reference Guide

<table>
<thead>
<tr>
<th>If you want to</th>
<th>Then do this:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Turn on the scanner</td>
<td>Press the I/O button on the front of the scanner to power on the scanner or launch the HT Array Plate Scanner application.</td>
</tr>
<tr>
<td>Load a plate</td>
<td>Click the Eject Stage button, a window opens prompting you to place the scan tray on the stage in the proper orientation. Click Close Stage.</td>
</tr>
</tbody>
</table>
| Select individual arrays (wells)                      | 1. Check the Manual Array Selection box or click Tools → Manual Array Selection Mode.  
|                                                       | 2. Position the cursor over the selected well and click the left mouse button. |
| Select multiple arrays (wells)                        | Alt-click on multiple arrays.                                                |
| Clear, or de-select, an array                         | Alt-click on a previously selected array, or to de-select multiple arrays, hold Alt and drag the mouse cursor over the particular arrays. |
| Attach a name to the array plate                      | Enter the information in the Scan Name field.                                |
| Manually add a barcode (in the event that the scanner cannot read the plate’s barcode) | 1. Click the Specify Plate Information button on the main window.  
|                                                       | 2. If there is a barcode, read the plate barcode and enter it in the Human Readable Barcode field.  
|                                                       | 3. If you need to remove the plate from the scanner in order to read the barcode, click Eject Stage to extend the array plate. The barcode must be exactly 22 characters long.  
|                                                       | 4. If the barcode is valid, the software will automatically select the plate type. |
Table 2.1
Quick Reference Guide (Continued)

<table>
<thead>
<tr>
<th>If you want to:</th>
<th>Then do this:</th>
</tr>
</thead>
</table>
| Manually add plate or scan information if no barcode exists | 1. Click the Specify Plate Information button on the main window.  
2. Select the plate type from the dropdown list (you can confirm the plate type since this information is on the plate label itself).  
3. You must then enter a unique name for your plate scan. This will become part of the name of the resulting .dat file.  
4. When you have completed entering the barcode information, click OK. |

<table>
<thead>
<tr>
<th>Determine the amount of hard disk space</th>
<th>Click Tools → Check Available Disk Space...</th>
</tr>
</thead>
<tbody>
<tr>
<td>Start a scan</td>
<td>Click the Start Scan button</td>
</tr>
<tr>
<td>Abort, or stop, the scan run</td>
<td>Click the Abort button</td>
</tr>
<tr>
<td>Unload, or eject, an array plate</td>
<td>Click the Eject Stage button</td>
</tr>
<tr>
<td>View the HT array plate .dat image progress</td>
<td>Observe the array progress on the Overall Status field.</td>
</tr>
<tr>
<td>Add a unique name or identifier to the .dat files</td>
<td>Enter the information in the Scan Name field. The name must be unique and the number of characters must not exceed 32.</td>
</tr>
<tr>
<td>View the log file</td>
<td>Click File → Open Log File... or press Ctrl+O.</td>
</tr>
</tbody>
</table>
| Turn off the scanner                          | If you pressed the I/O button to power on the scanner, then press the I/O button on the front of the scanner to power off the scanner.  
If you powered on the scanner by launching the HT Array Plate Scanner application, then simply exit the application (File → Exit). |

Checking Hard Disk Space

If you would like to confirm the amount of hard disk space on your workstation, click Tools → Check Available Disk Space. A window will appear with this information (Figure 2.7).

Figure 2.4
The Disk Space Check window
Setting Up the HT Array Plate Scanner

Installing the Scanner

Make sure the area for the scanner has the following features:

1. Adequate clearance around the scanner (Figure 2.5). Refer to the HT Array Plate Scanner Site Prep Guide (P/N: 08-0257) for more details.

![Figure 2.5](ht-array-plate-scanner-clearance.png)

2. 25 inches of space or more above the scanner’s topmost point
3. Access to facility power
4. Flat, level floor, with a solid, stable table to support the scanner and workstation.
5. 100-240V to the scanner using the provided cable and the receptacle in the lower rear right corner.

Connect the scanner to the PC using the provided cables (Figure 2.6).
The Firewire (IEEE 1394 High Speed Serial Bus) cable is not a locking connector. Insure that the Firewire cable is plugged securely and in the correct orientation in both the scanner and the workstation. Avoid snagging or pulling this cable during the scanner operation.
Uninterruptible Power Supply

Affymetrix recommends connecting the scanner to a UPS (Uninterruptible Power Supply) especially when scanning a 96-well plate overnight.

The recommended specifications for the USA are as follows:

- UPS-120V, 60Hz, 2.2KW/3.1KVA, ferrores isolating
- 3.1KVA/2.2KW ferrups 60Hz UPS
- 14 min. full load; 35 min. half load run time
- 120VAC input, 120VAC output
- Fixed input power cord with NEMA L5-30P plug
- QTY 3 NEMA 5-20R duplex output receptacles

For international users, since specifications can vary by country, you should provide the approximate UPS for your particular country based on the US specifications or with the assistance of local technical support.

CAUTION

The USB cable is not a locking connector. Insure that the USB cable is plugged securely and in the correct orientation in both the scanner and the workstation. Avoid snagging or pulling this cable during the scanner operation.
POWERING THE SCANNER AND LAUNCHING THE HT SCANNER CONTROL SOFTWARE

There are two ways to power on and off the HT Scanner.

Manually turning on/off the scanner

1. Press the I/O button (located on the scanner front panel).
2. Turn the workstation on.
3. Using the user interface, log into the computer.
4. Click the Affymetrix GeneChip HT Array Plate Scanner icon to run the software application and display the main screen. The application initializes the scanner and homes all motors.
5. To power off the scanner: press the I/O button. Note that exiting the software itself will not turn the scanner off if you used the I/O button to turn it on.
6. Close the GeneChip HT Array Plate Scanner software.

IMPORTANT

If you manually turn on the scanner, you must manually turn it off.

Automatically turning on/off the scanner

1. Turn the workstation on.
2. Using the user interface, log into the computer.
3. Click the Affymetrix GeneChip HT Array Plate Scanner icon to run the software application and display the main screen. The software application will automatically power on the scanner, initialize the scanner and home all motors.
4. To power off the scanner: exit the HT Array Plate Scanner software. Do not press the I/O button.
Main Command and Control Window

The application’s main control window (Figure 2.7) provides the command and control of the scanner. This allows you to select particular well plate and HT array plates and to observe the scanner’s operation.

Main Control Window components

Scanner Image

The Scanner Image window displays the image captured by a scanner’s camera. This typically shows a subarray or an L-shaped or square fiducial.

Overall Status

The Overall Status window records all of the scanner’s actions. The information from this window is saved daily to a log file that technicians can use for troubleshooting.
Plate Status

The Plate Status graphically illustrates the arrays on each particular array plate and will be different depending upon the type of array (human, mouse, etc.). This window has a grid of squares, 8×12, indicating the arrays on a HT array plate. The color of each square indicates its status before and during a run. See Table 2.2.

Table 2.2
Guide to the Color Status of Array

<table>
<thead>
<tr>
<th>If the Square is:</th>
<th>This means:</th>
</tr>
</thead>
<tbody>
<tr>
<td>Blue</td>
<td>You selected the array to be scanned during the next run</td>
</tr>
<tr>
<td>White</td>
<td>You did not select the array to be scanned during the next run.</td>
</tr>
<tr>
<td>If a square is light green with a black border</td>
<td>The scanner is processing the array.</td>
</tr>
<tr>
<td>If a square is dark green</td>
<td>The scanner has completed scanning the array.</td>
</tr>
<tr>
<td>Red</td>
<td>If a square is red, the array encountered an error and was not scanned successfully. The application may display an error message. The scanner will continue on to the next array.</td>
</tr>
</tbody>
</table>

Eject Stage Button

Clicking this button ejects the stage.

Click Eject Stage to extend the plate stage. Place a scan tray on the stage. Click OK to move the stage into the scanner.

If the door or the stage jams at any time, the software will display the following fatal message (Figure 2.8).

Figure 2.8
The fatal message that signals a jammed door or stage

a. Click OK. Exit the application, remove the obstruction and re-launch the application. If the problem persists, contact Affymetrix technical support.
Start Scan Button
With a scan tray and HT array plate already loaded onto the stage, click Start Scan to scan the arrays.

Scan Name
You can add your own unique label, or identifier, to each of the .dat file names that are created during a run. Place the cursor in the Scan Name field. The Unique ID dialog window opens. Add your information and click OK (Figure 2.9). The name must be unique and the number of characters must not exceed 32. This allows you to scan the array plate again and save additional .dat files made during the same run.

![Plate Properties Table]

Figure 2.9
The Scan Name field. It must be unique and not more than 32 characters long.
Scanning HT Array Plates

The following steps explain how to scan an Affymetrix HT array plate.

1. Obtain the array plate that has been processed by the GCAS system. The GCAS system will place the HT array plate into a scan tray for processing (Figure 2.10).

![Figure 2.10](image)

The HT array plate loaded on to a scan tray

2. Launch the HT Scanner software. The main window opens (Figure 2.11).
3. Click **Eject Stage** to eject the scan tray stage. A window appears prompting you to load the scan tray (Figure 2.12).
4. Place the scan tray on the stage in the proper orientation (Figure 2.13).
Figure 2.13
Load a plate - align plate carefully on the four tabs and take care not to spill buffer

CAUTION
It is crucial that you load the scan tray in the proper orientation and ensure that you seat the tray snugly and securely on the stage tabs. Note that the barcode faces the rear of the scanner.
5. Click **Close Stage** (Figure 2.12). The software will read the barcode on the array plate. If for some reason, the barcode reader does not detect a barcode, a new main window (Figure 2.18 on page 43) will appear with a new button for manually entering a barcode. See the section entitled *Manually Entering a Barcode* on page 43.

6. In the main window, select individual arrays or all the arrays (Figure 2.14).

---

**IMPORTANT**

Note that the library files, or media files, determine the GUI display of a particular array configuration for each type of array plate (human, mouse, etc.). See the GUI representation of the arrays in the plate status area in **Figure 2.14 on page 40** as an example.
40 GeneChip® HT Array Plate Scanner User's Guide

7. Click Start Scan to begin. The instrument will autofocus prior to scanning selected wells. This will have a duration of approximately one minute, fifteen seconds. The current array will appear light green surrounded by a black border (Figure 2.16).

Figure 2.14
The HT Scan Control window—one array selected, check the Manual Array Selection box before selecting arrays. Note that the library files, or media files, determine the GUI display of a particular array configuration for each type of array plate (human, mouse, etc.).


b. Select the arrays either by clicking each array, or by dragging the mouse cursor to select multiple arrays.

c. To de-select an array, Alt-click on an array, or to de-select multiple arrays, hold Alt and drag the mouse cursor over the particular arrays.

Notes:
- The library files, or media files, determine the GUI display of a particular array configuration for each type of array plate (human, mouse, etc.).
8. To abort the run, click **Abort**, then click **Done**. If want to rescan the array, click **Restart Scan** or, if not, click **Eject Stage**.

If for some reason there is an autofocus failure, a warning message will appear at the end of the complete scan run instruction you to clean the array plate (Figure 2.15). At present there are no troubleshooting tips. Contact Affymetrix technical support.

![Figure 2.15](Autofocus Failure message — contact Affymetrix technical support)

9. Once scanning has begun, the Scanned Image window will display the scanned image in real time, the overall status window will display the progress of the scan, and the currently scanned array box will be light green (Figure 2.16). The Overall Status window will display the current scan run status.
After scanning has completed, and if no errors have occurred, the wells selected will be dark green. The software will display the load plate window (Figure 2.12 on page 37) prompting you to load another plate. Either load another plate, or if you are finished scanning, click Close Stage.

If you are finished, click ☑ to close the software and shut down the scanner.
**Manually Entering a Barcode**

If the software does not detect a valid barcode associated with the array plate, an error message will appear and will prompt you to enter identifying information (Figure 2.17).

![Figure 2.17](image)

*Figure 2.17*
If the scan plate does not have a valid barcode, you must manually enter the barcode if this window appears.

When you click OK, the main window will change to one requiring you to add the missing information (Figure 2.18).

![Figure 2.18](image)

*Figure 2.18*
The Manual Barcode Entry window
Either click Eject Stage to eject the plate for you to visually read the barcode, or, if there is no barcode, click Specify Plate Information to manually enter a barcode or an identifying ID. To manually enter plate information, follow this procedure.

1. Click Specify Plate Information (Figure 2.19). A new window opens and prompts you to add barcode information (Figure 2.19).

![Figure 2.19](image)

**Figure 2.19**
The Specify Plate Information window—enter the barcode in this window, the barcode must be exactly 22 characters long. You can also enter a unique scan name.

2. If there is a barcode, read the barcode that is on the plate and add it to the Human Readable Barcode field. If you need to remove the plate from the scanner in order to read the barcode, click Eject Stage to extend the array plate (Figure 2.19). If the barcode is valid, the software will automatically select the plate type. If the barcode that you entered is not valid, the software displays an error message (Figure 2.20).

**IMPORTANT**

If you try to cancel manual barcode entry, a warning appears indicating that if you have not fully specified the plate information, you cannot scan the plate.
If the barcode is not exactly 22 characters in length, the OK button will not be enabled.

3. If there is no barcode, you can add a unique identification to each of the scan runs that produces .dat files for the plate. In the Unique Scan Name field, add your information (Figure 2.19). This will become part of the names of the resulting .dat files (see Figure 2.9 on page 34).

4. When you have completed entering the barcode information, click OK.

5. If you decide not to continue, click Cancel.

**Shutting Down**

After the run is complete, the software will notify you that the run has been completed. The stage will extend the scanned tray. Remove the scan tray. Click Exit to close the application. The GUI will shut down the scanner.

If you turned on the scanner using the front I/O button, press this button to turn off the scanner.
Chapter 3 MAINTENANCE AND TROUBLESHOOTING

Cleaning and Maintenance

The GeneChip® HT Array Plate Scanner requires little in the way of customer maintenance. The instrument must be kept clean and free of dust. Dust buildup can degrade performance. Wipe the exterior surfaces clean using a mild dish detergent solution in water. Do not use ammonia based cleaners or organic solvents, such as alcohol or acetone, to clean the system because they may damage the exterior surfaces.

The following tasks should be performed regularly to ensure the scanner remains in working order.

Monthly

Wipe down the outer surface of the scanner with a dry cloth.

Every Six Months

Replace cooling fan air filter. Contact Affymetrix Technical Support for instructions.

Troubleshooting

This chapter provides instructions on how to identify and solve simple problems with the scanner. If a problem or error occurs that is not listed in this chapter, contact a Affymetrix technical support for assistance.

For software errors that do not involve hardware crashes, the most common solution is to shut down the application and then restart it. If the same error occurs, shut down both the application and the computer and then restart. If it still occurs, shut down the entire scanner and then restart.

The following tables list problems and error messages you may see if a problem occurs.
### Power Problems

<table>
<thead>
<tr>
<th>Symptom</th>
<th>Probable Cause</th>
<th>Possible Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>The scanner cannot be powered up, or does not run properly.</td>
<td>Power has been disconnected.</td>
<td>Check the connections to facility power, and make sure that they are secure.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shut down and restart the application.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shut down and restart the computer.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>Shut down and restart the scanner.</td>
</tr>
</tbody>
</table>

### Error Messages

<table>
<thead>
<tr>
<th>Error Message</th>
<th>Probable Cause</th>
<th>Possible Solutions</th>
</tr>
</thead>
<tbody>
<tr>
<td>(axis name): Mwait() timeout; calls to IsInPosition() before timing out.</td>
<td>An axis error, call Affymetrix technical support for service.</td>
<td></td>
</tr>
<tr>
<td>Final following error:</td>
<td></td>
<td></td>
</tr>
<tr>
<td>(axis name) is not enabled (amp disabled or open loop)</td>
<td>An axis error, Call Affymetrix technical support for service.</td>
<td></td>
</tr>
<tr>
<td>(axis name) not homed.</td>
<td>An axis error, call Affymetrix technical support for service.</td>
<td></td>
</tr>
<tr>
<td>(axis name): positive/negative HW limit violated</td>
<td>An axis error, call Affymetrix technical support for service.</td>
<td></td>
</tr>
<tr>
<td>Fatal Hardware Error (including autofocus error, plate jam condition and</td>
<td>Call Affymetrix technical support for service.</td>
<td></td>
</tr>
<tr>
<td>power down failure)</td>
<td></td>
<td></td>
</tr>
</tbody>
</table>
Introduction

The HT Image Reader software together with the GCOS software system is used to analyze and manage the data generated by the HT Scanner.

At the core of the software system is the GCOS Server software. This software provides for centralized data management and analysis capabilities for the Affymetrix GeneChip arrays. Multiple client workstations may be connected to this server for data access. The GCOS Server uses an Oracle® or SQL Server database engine to store information relating to the workflow and analysis of GeneChip array data. With each GeneChip array, a user may associate its defined sample and experiment attributes.

The GCOS Client software, connected to the GCOS Server, may be used to view, modify or add attributes to an experiment and or sample, invoke analyses including comparative analyses, view the GeneChip arrays’ intensity data, publish the analysis results to an AADM compliant database or other various tasks. Please refer to the GCOS Users’ Manual for information regarding the GCOS application.

Integrated with the GCOS software system are the HT Image Reader and HT Data Transfer software. These software applications provide for the analysis workflow of the GeneChip Array Station.

The HT Image Reader software integrates with the GCOS system to provide analysis and data management functionality specific to the GeneChip Array Station. In addition to data analysis capabilities, this software provides the interfaces for associating sample plate and HT Array Plate barcodes which are subsequently associated with the GeneChip array data.

From within this software you can invoke an analysis on an HT Array Plate and view the status of the analysis workflow.

HT Image Reader Application Layout

1. The HT software application contains three main windows. These are the “Array Analyzer”, “Workflow Status” and “Image Display” windows. There is only one “Array Analyzer” or “Workflow Status” window. Multiple images may be displayed, each within its own image display window (Figure 4.1).
Getting Started

Analysis Options

Prior to analyzing data with the HT Image Reader software you will need to ensure that the analysis and report parameters have been properly specified. Your analysis options are saved from session to session and are displayed using the Analyze → Options menu command.

E-mail Alert Options

The software has the capability to send an email upon analysis failure. The software will email the same text message that appears in the workflow status message window to a user-specified email address. Use the Analyze → Email Alert Options menu command to configure the email alert options.
Publish Database

The software has the capability of instructing the GCOS software to publish the analysis results to an AADM database. The AADM database must be created prior to invoking this feature of the software. Use the GCOS Manager tool to create and manage AADM databases.

GCOS Mode

The HT Image Reader software operates in the same mode as defined by the GCOS software. The modes are either local or server mode. Prior to starting or installing the HT software, set the appropriate mode in the GCOS application. Use the Tools → Defaults menu item in the GCOS software to specify the GCOS operation mode.

Invoking An Analysis

Once the system has been properly configured it is ready to analyze HT Array Plate acquisition data.

Rescanning An HT Array Plate

If a rescan of the HT Array Plate or individual well is needed, you must first delete the old acquisition data.

Analysis Options

The available options are:

Auto Invocation Parameters

These options are to enable the software to automatically run an analysis upon completion of all scan acquisitions for a well. The data transfer tray software will start this application and the analysis will begin only if properly configured.

Invoke analysis upon scan complete message

This option specifies whether the analysis of an HT Array Plate/well is to begin when the software receives a message that all acquisitions have been made for a given HT Array Plate/well.

Default Plate Type

When an analysis automatically starts, the value in this drop down list is the value to use for the plate type. This value will be used only if the software cannot determine the plate type from the barcode value.
Scanner Information

This section stores the scanner ID of the HT scanner. This value is stored in the GCOS system as part of the scan parameters.

Multi-Scan Parameters

The scanner system has the capability of performing multiple exposure time acquisitions for each well. These parameters are used to configure the analysis software as to how many exposures were used.

Number of image scans

This option specifies how many exposures (1 or 2) are to be used in the analysis.

Analysis Parameters

The software will instruct the GCOS system to analyze the resulting intensity data (CEL file). These parameters are used to instruct the software on if and how the analysis should occur. Note: use the GCOS software to specify the algorithm’s parameters.

Probe array analysis

Specifies whether a probe array analysis is to be performed. The results of the probe array analysis are stored in a CHP file.

Analysis Name Suffix

Used to add a suffix to the name of the file storing the analysis results.

Analysis Results Checks

Once the analysis results have been computed for a well the software will optionally perform a series of range checks. These parameters are used to instruct the software on if and how the range checks should occur. If the software detects that any of the specified parameters are out of range, the software will notify the user by displaying an error message and sending an email (if configured) and stop the processing of the well. The remaining step in the well process will not occur if the boundary conditions fail—the final step in the workflow is the publishing of the results to an AADM database. This is an optional step and is available if and only if the probe array analysis is selected.

Perform checks

Specifies whether the software should check the values of certain analysis results to ensure they are within your user defined thresholds. Those analyses that do not pass this range threshold checking will be flagged as failed and the workflow will stop. The resulting CEL and CHP files will remain in the GCOS system.
**Results Check Parameters**

Displays the results check parameters options dialog to allow you to specify which results are to be checked and to define the minimum and maximum values and weight for each result. The parameters are specific to the probe array type and must be set prior to having the software perform the range check function.

**Publish Parameters**

The GCOS software uses AADM database to provide a method for transferring Affymetrix results to other systems. These parameters define the AADM database to publish the analysis results to. This is an optional step and is available if and only if the probe array analysis is selected.

**Publish analysis results**

Specifies whether the analysis results should be published to a GCOS AADM database.

**Publish Database**

The name of the AADM database to publish the results to.

**Password**

The database password.

**Overwrite**

A flag indicating if any prior analysis results should be overwritten.

**Publish Intensities**

A flag indicating if intensity level data are to be published.

The following screen shots show the workflow options dialog and range checking options dialogs (Figure 4.2).
Results Check Options

When the “Analysis Results Check” option is selected the software will check to see if the selected values fall within the specified ranges. See Figure 4.3 and Figure 4.4.

For Expression: RawQ, %Present, #Present, %Absent, #Absent, %Marginal, #Marginal, BG, Noise, Signal (all), Registration, Spike or Housekeeping control probe set are available for the range checks. Only one spike or housekeeping control may be checked and is determined by the “Spike/House Name” input and the “Control metric” selection (3’, 5’, middle or 3’/5’). Refer to the GCOS manual for an explanation of these metrics. The registration metric is a percentage of those dim and bright control features and non-synthesized features that exceed a computed threshold.

For Mapping: Call Rate, #AA, #AB, AFFX-5Q-123, AFFX-5Q-456, AFFX-5Q-789, AFFX-5Q-ABC or Registration are available for range checks. The registration metric is a
percentage of those dim and bright control features and non-synthesized features that exceed a computed threshold.

The method for determining if a well passes the range check is as follows:

1. For each metric selected (check-marked) the software computes a score. The score is a function of the distance between the metric value and its closest boundary threshold value. The farther the metric value is from the threshold boundary, the higher the score.

   - Let \( L = \text{Min Threshold} \)
   - Let \( M = \text{Max Threshold} \)
   - Let \( T = (\text{Max Threshold} - \text{Min Threshold}) / 2 \)
   - Let \( V = \text{value of the metric to test. i.e. RawQ} \)
   - Let \( W = \text{weight of the metric} \)
   - Let \( S = \text{the test statistic score} \)
   - If \( (V < L) \) then let \( S = (L-V) * W / T \)
   - If \( (V > M) \) then let \( S = (V-M) * W / T \)
   - Otherwise \( S = 0 \)
   - Now constrain \( S \) to be not more than \( W \) (i.e. let \( S \) be the minimum of \( S \) and \( W \))
   - The resulting \( S \) value can range from 0 to \( W \)

If the sum of the scores for all selected metrics exceed the “Weight Threshold” value then a the well is assigned a value of 0, otherwise the well is assigned a value of 1. A “0” value indicates that the well has not passed the threshold criteria.
Figure 4.3
The Analysis Results Check Options window for expression
E-mail Alerts

Error messages generated during the analysis of an HT Array Plate will be displayed within the workflow status message window and optionally e-mailed to a user when an error message is posted (Figure 4.5). To enable the e-mail alert feature, you must specify a send-to e-mail address, IP address of your SMTP server, the port number used by the SMTP server and a timeout value in seconds.

The software will send an email to the user when error messages are generated during the analysis. The error message and date and time of the error will be included in the email notification.
Invoking an Analysis

Invoking an analysis on an HT Array Plate is the process of transferring the image data acquired by the HT Scanner Console software to the GCOS server, creating the GCOS experiment and sample objects, and analyzing the image data creating intensity data results (CEL files) and probe array analysis results (CHP files) and publishing the results to an AADM database.

To invoke an analysis you must enter the following information in the array analyzer window (Figure 4.6):

1. Barcode or other unique identifier for the plate. Use the browse ("...") button to select the identifier. The list will show the available plates that have not yet been processed (if the Process workflow option is selected) or those that have already been processed (if the Requeue to grid or Requeue to intensity analyses option is selected).

2. The wells to analyze. You may use the Auto Select button to determine which wells are available or manually select those to analyze.

3. The plate type. The plate type maps the well position to probe array type.

4. A comment to be stored in the GCOS experiment object. The GCOS experiment object will not be updated if it already exists. This attribute is not required.

5. The process flag (Process workflow, Requeue to grid or Requeue to intensity analysis).
   - The Process workflow option should be used for analyzing plates for the first time or to restart an analysis if the analysis was interrupted for any reason.

---

**Figure 4.5**
E-mail Alert Options window

---

*Send email upon analysis errors.*

**To:**
user@domain.com

**SMTP Server:**
127.1.1.1

**Port Number:**
25

**Timeout:**
2

---

**Invoking an Analysis**

Invoking an analysis on an HT Array Plate is the process of transferring the image data acquired by the HT Scanner Console software to the GCOS server, creating the GCOS experiment and sample objects, and analyzing the image data creating intensity data results (CEL files) and probe array analysis results (CHP files) and publishing the results to an AADM database.

To invoke an analysis you must enter the following information in the array analyzer window (Figure 4.6):

1. Barcode or other unique identifier for the plate. Use the browse ("...") button to select the identifier. The list will show the available plates that have not yet been processed (if the Process workflow option is selected) or those that have already been processed (if the Requeue to grid or Requeue to intensity analyses option is selected).

2. The wells to analyze. You may use the Auto Select button to determine which wells are available or manually select those to analyze.

3. The plate type. The plate type maps the well position to probe array type.

4. A comment to be stored in the GCOS experiment object. The GCOS experiment object will not be updated if it already exists. This attribute is not required.

5. The process flag (Process workflow, Requeue to grid or Requeue to intensity analysis).
   - The Process workflow option should be used for analyzing plates for the first time or to restart an analysis if the analysis was interrupted for any reason.
The Requeue to grid option will instruct the software to invoke the grid alignment algorithm on the sub-image data. Analysis steps in the workflow after the grid alignment process will also be invoked.

The Requeue to intensity analysis will instruct the software to invoke the CEL creation algorithm on the sub-image data. Merging of all of the intensity data into a single CEL file representing the intensity of all features of the array will also be performed.

![Figure 4.6](image)
The Array Analyzer window
MENU COMMANDS

The Analyze menu is available with the Array Analyzer window with the following commands (menu items).

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Analyze Plate</td>
<td>Invokes an analysis on the specified plate.</td>
</tr>
<tr>
<td>Options</td>
<td>Shows the analysis options dialog.</td>
</tr>
<tr>
<td>Move image data to GCOS system</td>
<td>Transfers the image data files to the GCOS server without invoking an analysis.</td>
</tr>
</tbody>
</table>

Workflow Status Messages

The workflow for analyzing an HT Array Plate is performed on the GCOS server. Once the analysis has been queued, the HT Image Reader software may be closed and you may even log out of or turn off the client workstation.

During the analysis of the HT Array Plate data, the HT Image Reader software will record status messages to a database. These messages may be viewed within the Workflow Status window (Figure 4.7) in real time (as the analysis proceeds and messages recorded) or by querying the database for previously recorded messages.

Messages include workflow status messages, error messages, warning messages or informational messages. Error messages are shown in red to easily distinguish them from non-error messages.

The date and time, barcode, well position and if suitable the file name, will be displayed as part of the status message.
Menu Commands

A popup menu, and the application’s Messages menu, is available in the Workflow Status window with the following commands (menu items).

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Query</td>
<td>Shows the query message dialog</td>
</tr>
<tr>
<td>View Active</td>
<td>Toggles the real-time display of the status messages for any in-progress analysis.</td>
</tr>
<tr>
<td>Messages</td>
<td></td>
</tr>
<tr>
<td>Auto scroll</td>
<td>Scrolls the list to the bottom when a new message is added.</td>
</tr>
<tr>
<td>Clear</td>
<td>Clears all status messages from the display.</td>
</tr>
<tr>
<td>Export</td>
<td>Exports the status messages to a log file.</td>
</tr>
</tbody>
</table>

Query Messages

All messages are stored in a database on the GCOS Server for later querying. Use the “Query Message” dialog to define the filter criteria for the query.

The available filter criteria are (Figure 4.8):

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Filter Barcode</td>
<td>Enter the plate barcode. The value must be exact and is case sensitive. Leave the value blank to return messages for all plates.</td>
</tr>
</tbody>
</table>
Opening an Image File

The image display allows you to view and modify the border which defines the area within a given sub-image. This is also referred to as the sub-image’s grid.

1. Click File → Open command to open a sub-image (Figure 4.9).
   
   This command will display the Open Image Data dialog.

2. In the open Image Data Dialog select the barcode, well and sub-image index to open the desired image file.

3. Check the “All on grid queue” to open all images where the grid alignment algorithm failed to determine the grid coordinates associated with the specified plate barcode.

Once specified, the image data will appear within the software, one sub-image per window.

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Severity</td>
<td>Select the message severity or all message types.</td>
</tr>
<tr>
<td>Lower Date</td>
<td>The messages returned will be those after the specified date and</td>
</tr>
<tr>
<td>Range</td>
<td>time.</td>
</tr>
<tr>
<td>Upper Date</td>
<td>The messages returned will be those before the specified date and</td>
</tr>
<tr>
<td>Range</td>
<td>time.</td>
</tr>
</tbody>
</table>

*Figure 4.8*
The Query Messages window
For each well position, which is to say for each probe array, multiple image acquisitions are performed. The software will combine the data acquired from the multiple images to produce the end analysis results. The display functionality of the software is such that each acquisition is displayed in a separate image display window. When opening an acquisition for display it is important to specify the sub-image index along with the well and barcode values.

The indices range from a value of 0 to N-1 where N is the number of sub-images in the array. The top left acquisition is labeled index 0, and indices increase to the right by columns then down by rows.

As an example, for an array where 9 acquisitions were made (3 rows and 3 columns of acquisitions), the following graphic shows the index values.
Image Display

The image display window (Figure 4.10) will display a single sub-image. The purpose of this window is to allow you to view the image and allow the modification of the grid coordinates. The grid is defined as the pixel coordinate for the upper left, upper right, lower left and lower right corners of the defined area.

![Image Display](image.png)

Figure 4.10
The Image Display window
Commands available within the image display are:

**File Menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Close</td>
<td>Closes the image window.</td>
</tr>
<tr>
<td>Save</td>
<td>Updates the acquisition file given the newly defined grid coordinates.</td>
</tr>
<tr>
<td>Print</td>
<td>Prints the image.</td>
</tr>
</tbody>
</table>

**Edit Menu**

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>This command will copy the selected region to the Windows copy buffer to allow pasting of the selected region to a separate application.</td>
</tr>
</tbody>
</table>

**Popup Menu (right click within the image window)**

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Copy</td>
<td>Copies the selected region to the Windows clipboard.</td>
</tr>
<tr>
<td>Image settings</td>
<td>This command will show the image settings dialog.</td>
</tr>
</tbody>
</table>

**Command Bar (bottom of image window)**

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Auto</td>
<td>Defines the intensity range for display based on the pixel values in the user selected region.</td>
</tr>
<tr>
<td>Grid</td>
<td>Toggles the grid display.</td>
</tr>
<tr>
<td>Avg</td>
<td>Computes the average pixel value for the selected region.</td>
</tr>
<tr>
<td>In</td>
<td>Zooms in.</td>
</tr>
<tr>
<td>Out</td>
<td>Zoom out.</td>
</tr>
<tr>
<td>Full</td>
<td>Shows the entire image in the window.</td>
</tr>
<tr>
<td></td>
<td>Zoom to grid corner.</td>
</tr>
</tbody>
</table>
Shortcut Keys

The following are the list of shortcut keys for the image display window. Short cut keys are case sensitive.

<table>
<thead>
<tr>
<th>Key</th>
<th>Action</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl-c</td>
<td>Copy the selected region to the Windows clipboard.</td>
</tr>
<tr>
<td>s</td>
<td>Show the image settings dialog.</td>
</tr>
<tr>
<td>g</td>
<td>Toggle the grid display - on or off.</td>
</tr>
<tr>
<td>i</td>
<td>Zoom in.</td>
</tr>
<tr>
<td>o</td>
<td>Zoom out.</td>
</tr>
<tr>
<td>O (capital o)</td>
<td>Full zoom out.</td>
</tr>
<tr>
<td>F5</td>
<td>Zoom to upper left corner.</td>
</tr>
<tr>
<td>F6</td>
<td>Zoom to upper right corner.</td>
</tr>
<tr>
<td>F7</td>
<td>Zoom to lower left corner.</td>
</tr>
<tr>
<td>F8</td>
<td>Zoom to lower right corner.</td>
</tr>
</tbody>
</table>

Image Settings

The image display may be modified using the Image Settings dialog window (Figure 4.11). This dialog window allows you to change the scale and colors used. The options for the scale are either Autoscale, where the software calculates the color palette or greyscale range from the brightest and dimmest pixels in the image, or else user-defined limits for the color palette or greyscale range.

The color palette options are either a gray scale or pseudo color scale. The software uses a linear mapping between the minimum and maximum pixel values and color palette. You can add a color bar to the image display window showing the color palette.

You can adjust the color for the grid overlay by using the Highlights... button. A color chooser will appear allowing the user to specify the color to use for the grid overlay.
Well to Experiment Mapping

By default the HT Image Reader software will automatically name the GCOS experiment and sample using the scan plate barcode and well position. See Appendix I – GCOS Objects on page 75 for the default values for the GCOS experiment and sample.

The software provides the ability for the user to override this default behavior by specifying a mapping from plate barcode and well position to experiment and sample attributes.

Creating the Mapping

Use the Tools → Map Well to Experiment menu command to define the mapping between well position and experiment and sample attributes. Invoking this command will prompt you to select an ASCII text file with the mapping information. The software will read the information in the text file and store it for latter use when processing the HT Array Plate. A standard Windows file open dialog will be displayed prompting the user for the input mapping file.

The mapping between well positions and GCOS experiment and sample names must be made prior to analyzing the well.

The format of the text file must be ASCII text, tab- or comma-delimited. The file will contain a line for each well position to map. Not all wells are required to be mapped, only those of interest. The text file shall not contain any header lines, only data for mapping HT Array Plate well to GCOS object. The columns of the text file are:
1. The plate barcode (this value is required).
2. The well position. Must be A01 – A12 → H01 – H12 (this value is required).
3. The GCOS experiment name (this value is required).
4. The GCOS sample name (this is optional).
5. The GCOS sample project (this value is optional).
6. The GCOS sample type (this value is optional).

The last three columns, those that define GCOS sample attributes, are optional. Those columns must either be all there (all three sample attributes) or all missing.

An example of a text file is:

```
hta_test_data B12 myexp mysample myproj mytype
```

This example maps well B12 of plate “hta_test_data” to a GCOS experiment named “myexp” with a sample named “mysample” with sample project named “myproj” and sample type named “mytype”.

**Viewing the Mapping**

To show the mapping between a well and GCOS experiment, use the Tools → Show Well To Experiment Map menu command.

Invoking this command will display the Plate to Experiment Mapping window (Figure 4.12).
Enter the barcode, or plate identifier, in the Plate Barcode field and move the mouse over the desired well. The GCOS experiment and sample attributes associated with the plate and well will be displayed.

You may use this dialog to change the value of the GCOS experiment and sample name for an individual well. To modify the mapping, double-click on a well position. This will show the Plate/Experiment Mapping Information dialog (Figure 4.13).

Figure 4.12
The Plate to Experiment Mapping window

Enter the barcode, or plate identifier, in the Plate Barcode field and move the mouse over the desired well. The GCOS experiment and sample attributes associated with the plate and well will be displayed.

You may use this dialog to change the value of the GCOS experiment and sample name for an individual well. To modify the mapping, double-click on a well position. This will show the Plate/Experiment Mapping Information dialog (Figure 4.13).
To change the mapping information, enter the new information in the Experiment Name, Sample Name, Sample Project and Sample Type edit fields and click the OK button. Note that the mappings must be specified prior to analyzing the acquisition data.

Advanced Tools

The advanced tools provided in the Tools menu should be used only by advanced users. The tools provided will rename image data files acquired by the HT Scanner software and will manipulate the orientation of the images.

Rename Barcode

This tool will rename all sub-image data files associated with all wells of a specified plate barcode/identifier. Typically this is required only if the plate identifier is longer in length than the allowable length of 55 characters. Only those data files that have not yet been processed (transferred to the GCOS Server) are available to this tool.

To use the tool, enter the existing plate identifier in the Old value text field and the new plate identifier in the New value text field and press the Rename button.

When the renaming process is complete you may rename another plate or close the dialog.
Image Manipulation

This feature should be used by only the truly advanced user. This feature is provided to manipulate the orientation of the image files. The tool is capable of manipulating a single well or all wells.

To specify a single well enter the plate barcode, uncheck the All Wells check box and select the desired well from the Well drop down list.

To specify all wells of an HT Array Plate enter the plate barcode and check the All Wells check box.

Click the Process button to start the image manipulation. A progress meter will be displayed showing the progress of the function.

Deleting Acquisitions

The Delete Acquisitions dialog (Figure 4.14) is used to delete the acquisition files (DAT files) and workflow stage database entries associated with an HT Array Plate and well. This step is required when you must rescan a well to ensure the analysis is performed using the new acquisition data only. Rescanning without deleting the old acquisitions will potentially result in an analysis using old and new acquisition data.

Figure 4.14
The Delete Acquisitions window
To delete data:

1. Select the plate’s barcode value.
2. Specify the well locations (you can use the auto-select button to detect the available wells).
3. Click the Delete button to delete the data and reset the database entries in the workflow stage database.

A message box will appear asking you to confirm that you want to proceed with the deletion process.

**WARNING**

This action will permanently delete the data. There is no undo to this function.
## Menu Commands

The following are the list of menu commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>File → Open</td>
<td>Opens an image data file.</td>
</tr>
<tr>
<td>File → Close</td>
<td>Closes the active image window.</td>
</tr>
<tr>
<td>File → Save</td>
<td>Updates the image file given the user modified grid coordinates.</td>
</tr>
<tr>
<td>File → Print</td>
<td>Prints a hardcopy of the display.</td>
</tr>
<tr>
<td>File → Print Setup</td>
<td>Configures the print parameters.</td>
</tr>
<tr>
<td>File → Exit</td>
<td>Terminates the program.</td>
</tr>
<tr>
<td>Edit → Copy</td>
<td>Copies the selected region to the Windows clipboard.</td>
</tr>
<tr>
<td>View → Toolbar</td>
<td>Toggles the toolbar display.</td>
</tr>
<tr>
<td>View → Status Bar</td>
<td>Toggles the status bar display.</td>
</tr>
<tr>
<td>Analyze → Analyze Plate</td>
<td>Invokes an analysis on the selected plate and wells.</td>
</tr>
<tr>
<td>Analyze → Options</td>
<td>Shows the analysis options dialog.</td>
</tr>
<tr>
<td>Analyze → Email Alert Options</td>
<td>Shows the email alert options dialog.</td>
</tr>
<tr>
<td>Analyze → Move image data to GCOS system</td>
<td>Moves the image data to the GCOS system without invoking an analysis.</td>
</tr>
<tr>
<td>Messages → Query</td>
<td>Shows the query message dialog.</td>
</tr>
<tr>
<td>Messages → View Active Messages</td>
<td>Shows the messages from an analysis in real-time.</td>
</tr>
<tr>
<td>Messages → Clear</td>
<td>Clears the status message display.</td>
</tr>
<tr>
<td>Messages → Export</td>
<td>Exports the status messages to a log file.</td>
</tr>
<tr>
<td>Tools → Map Well to Experiment</td>
<td>Maps user defined experiment names to well positions.</td>
</tr>
<tr>
<td>Tools → Image</td>
<td>Shows the image tools dialog.</td>
</tr>
<tr>
<td>Tools → Rename Barcode</td>
<td>Shows the rename barcode dialog.</td>
</tr>
</tbody>
</table>
The following are the toolbar buttons and associated menu commands:

<table>
<thead>
<tr>
<th>Command</th>
<th>Toolbar Button</th>
</tr>
</thead>
<tbody>
<tr>
<td>File → Open</td>
<td>📥</td>
</tr>
<tr>
<td>File → Export</td>
<td>📝</td>
</tr>
<tr>
<td>File → Print</td>
<td>📨</td>
</tr>
<tr>
<td>Edit → Copy</td>
<td>📁</td>
</tr>
<tr>
<td>Analyze → Analyze Plate</td>
<td>📀</td>
</tr>
<tr>
<td>Analyze → Options…</td>
<td>🎦</td>
</tr>
<tr>
<td>Help → About</td>
<td>🤔</td>
</tr>
</tbody>
</table>

**Command**

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Tools → Delete Acquisitions</td>
<td>Deletes the acquisitions files (DAT files) and workflow stage database entries associated with a well.</td>
</tr>
<tr>
<td>WARNING: This should only be used prior to rescanning the well as the data are permanently deleted</td>
<td></td>
</tr>
<tr>
<td>Window → Tile</td>
<td>Tiles the image windows.</td>
</tr>
<tr>
<td>Window → Cascade</td>
<td>Cascades the image windows.</td>
</tr>
<tr>
<td>Window → Arrange Icons</td>
<td>Arrange Icons Arranges the image window icons.</td>
</tr>
<tr>
<td>Window → (Show/Hide) Array Analyzer Window</td>
<td>Show/Hide Array Analyzer Windows Toggles the display of the array analysis window.</td>
</tr>
<tr>
<td>Window → Show/Hide Workflow Status Window</td>
<td>Show/Hide Workflow Status Window Toggles the display of the status message window.</td>
</tr>
<tr>
<td>Help → About</td>
<td>Shows the about dialog.</td>
</tr>
<tr>
<td>Help → Help</td>
<td>Shows the help file.</td>
</tr>
</tbody>
</table>
Introduction

Appendix I – GCOS Objects

The HT Image Reader software communicates with the Affymetrix GCOS software for probe array analysis and publishing requests and to provide data management of the HT data. One of the tasks the HT Image Reader software performs with the GCOS software is the creation of GCOS objects. These objects are created during the processing of the acquisition data. The objects include the following items.

GCOS Experiment

A single GCOS experiment is created for each well of an HT Array Plate. The attributes of the GCOS experiment include:

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Combination of plate barcode and well with a &quot;.&quot; as a delimiter between values or user defined if using the well position to experiment name mapping functions.</td>
</tr>
<tr>
<td>User</td>
<td>The Windows user name of the user executing the HT Image Reader software.</td>
</tr>
<tr>
<td>Plate Barcode</td>
<td>The barcode of the scan plate.</td>
</tr>
<tr>
<td>Well</td>
<td>The well position.</td>
</tr>
<tr>
<td>Feature dimension</td>
<td>The dimension of each feature on the probe array.</td>
</tr>
<tr>
<td>Number subimage rows</td>
<td>The number of rows of sub-images per probe array.</td>
</tr>
<tr>
<td>Number subimage columns</td>
<td>The number of columns of sub-images per probe array.</td>
</tr>
</tbody>
</table>
Table 5.1
GCOS Experiment Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Name</td>
<td>Combination of plate barcode and well with a &quot;.&quot; as a delimiter between val-</td>
</tr>
<tr>
<td></td>
<td>ues, or user defined if using the well position to experiment name mapping</td>
</tr>
<tr>
<td></td>
<td>functions.</td>
</tr>
<tr>
<td>Type</td>
<td>Well number or user defined if using the well position to experiment name</td>
</tr>
<tr>
<td></td>
<td>mapping functions.</td>
</tr>
<tr>
<td>Project</td>
<td>Plate barcode or user defined if using the well position to experiment name</td>
</tr>
<tr>
<td></td>
<td>mapping functions.</td>
</tr>
<tr>
<td>User</td>
<td>The Windows user name of the user executing the HT Image Reader software.</td>
</tr>
</tbody>
</table>

GCOS Sample

A single GCOS sample is created for each well of an HT Array Plate. The attributes of the GCOS sample include:

Table 5.2
GCOS Sample Attributes

<table>
<thead>
<tr>
<th>Attribute</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Scan objective</td>
<td>The objective used.</td>
</tr>
<tr>
<td>Scan filter set</td>
<td>The filter set used.</td>
</tr>
<tr>
<td>Scan exposure time</td>
<td>The exposure time.</td>
</tr>
<tr>
<td>First scan time</td>
<td>The time the first sub-image was acquired.</td>
</tr>
<tr>
<td>Last scan time</td>
<td>The time the last sub-image was acquired.</td>
</tr>
<tr>
<td>User comment</td>
<td>A free form comment defined when invoking the analysis.</td>
</tr>
</tbody>
</table>
Appendix II – Data Access

Programmatic integration with the HT and GCOS systems and other external systems, including sample tracking and attribution systems, are enabled through the use of the commercially available Affymetrix SDKs. These SDKs provide programmatic access to the data, including process level, experiment attributes and analysis results data to enable both uploading and retrieval of information.

The following are a list of software developer kits (SDKs) available from Affymetrix to access information generated and stored by the HT and GCOS systems.

Files SDK

The HT Image Reader software’s generate data files (CEL and CHP) are capable of being accessed using the Affymetrix Files SDK.

GCOS SDK

The GCOS SDK provides the ability to interface with the data stored in the GCOS system. This includes experiment and sample information. Programmatic access to this information can be achieved using this SDK.

AADM Schema and SDK

The software utilizes the data publishing capabilities of the GCOS system to enable the publishing of expression results to an AADM database. Information stored in AADM database is accessible via direct SQL queries to the AADM schema or to the AADM SDK.

Expression Exporter SDK

By integration with the GCOS system, data generated by the software is accessible to the Expression Exporter SDK.
Appendix III – FAQ

The following are frequently asked questions about Affymetrix® GeneChip® HT Image Reader.

- Q. What operating systems are supported by the software?
  The software has been validated on Microsoft® Windows® 2000 Professional with Service Pack 4 and Microsoft® Windows® XP with Service Pack 1a.

- Q. Can the GCOS templates used by the software be modified?
  The name of the template and the existing attributes may not be modified. Additional attributes may be added.

- Q. Is it OK to create GCOS experiments in advance that do not use the Affymetrix defined HT template?
  Yes. The software will create experiments as needed but if one already exists for the well then it will be used (no updates performed). If experiments are created in advance of the acquisitions then any GCOS experiment template may be used.

- Q. What are the list of typical messages that may be generated by the HT Image Reader software?
  The following table describes the messages produced by the software (Table 5.3):

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Invalid character in barcode. The barcode must not contain one of the following:...</td>
<td>The system restricts the plate identifier (or barcode) to those characters not listed in the error message.</td>
</tr>
<tr>
<td>The barcode must be less than 55 characters.</td>
<td>The GCOS system has length restrictions for the names of the samples and experiments which translate to a 55 character limitation for the plate identifier (barcode).</td>
</tr>
<tr>
<td>Moving files to GCOS</td>
<td>This message indicates that the software is moving the acquisition files from the scan data directory to the GCOS data directory.</td>
</tr>
<tr>
<td>Creating GCOS experiment.</td>
<td>The software is creating a GCOS experiment for a well. Each well of an HT Array Plate will have one associated GCOS experiment.</td>
</tr>
<tr>
<td>Initiating image processing analysis.</td>
<td>The software is processing the sub-images (acquisition) files for the well. This includes the grid alignment, feature extraction, merging and alignment check algorithms.</td>
</tr>
</tbody>
</table>
Processing image data files. The software is starting the grid alignment and feature extraction processing of the acquisition files.

Processing <file_name.dat> The software is analyzing the acquisition file named <file_name.dat> The analysis consists of grid alignment to locate the corner checkerboard patterns and feature extraction to compute the intensity data.

Merging intensity data files. The software is merging the data from the short and long exposures.

Warning: Some feature intensity values are zero. This message indicates that one or more feature intensities were not calculated. The most likely cause of this is missing acquisition files.

Computing summary statistics on the intensity file. The software is checking the intensities of the bright and dark control features to verify successful alignment of each acquisition file.

Image processing analysis complete. The processing of each acquisition file to create a single intensity file (CEL) for a given well is complete.

Analyzing intensity data. The software is performing the probe array analysis (creating a CHP file).

Probe array analysis complete. The software successfully created the CHP file.

Publishing analysis results. The software in initiating the process of adding the analysis results to the GCOS publishing queue.

Adding to publish queue complete. The software successfully added the analysis to the GCOS publishing queue.

Failed to add to the publish queue. The software was unable to add the analysis to the GCOS publishing queue. Use the GCOS Manager software to view and troubleshoot the publish error.

The number of image files found did not match the expectation to create the intensity file: <file_name.CEL> The software must be told the number of exposures (1 or 2) that the scanner is acquiring for the analysis. This value is configured in the "Number of image scans" field of the Workflow Options dialog.

Analysis completed with errors. This message is given at the end of an analysis run to indicate that error messages were generated during the analysis run.

Failed to align image file: <filename.DAT> The software was not able to determine the location of the checkerboard alignment controls for the file <filename.DAT>. One cause may be due to the file being opened for display - the software can’t analyze a file that is open.

Table 5.3
HT Image Reader Generated Software Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Processing image data files.</td>
<td>The software is starting the grid alignment and feature extraction processing of the acquisition files.</td>
</tr>
<tr>
<td>Processing &lt;file_name.dat&gt;</td>
<td>The software is analyzing the acquisition file named &lt;file_name.dat&gt; The analysis consists of grid alignment to locate the corner checkerboard patterns and feature extraction to compute the intensity data.</td>
</tr>
<tr>
<td>Merging intensity data files.</td>
<td>The software is merging the data from the short and long exposures.</td>
</tr>
<tr>
<td>Warning: Some feature intensity values are zero.</td>
<td>This message indicates that one or more feature intensities were not calculated. The most likely cause of this is missing acquisition files.</td>
</tr>
<tr>
<td>Computing summary statistics on the intensity file.</td>
<td>The software is checking the intensities of the bright and dark control features to verify successful alignment of each acquisition file.</td>
</tr>
<tr>
<td>Image processing analysis complete.</td>
<td>The processing of each acquisition file to create a single intensity file (CEL) for a given well is complete.</td>
</tr>
<tr>
<td>Analyzing intensity data.</td>
<td>The software is performing the probe array analysis (creating a CHP file).</td>
</tr>
<tr>
<td>Probe array analysis complete.</td>
<td>The software successfully created the CHP file.</td>
</tr>
<tr>
<td>Publishing analysis results.</td>
<td>The software in initiating the process of adding the analysis results to the GCOS publishing queue.</td>
</tr>
<tr>
<td>Adding to publish queue complete.</td>
<td>The software successfully added the analysis to the GCOS publishing queue.</td>
</tr>
<tr>
<td>Failed to add to the publish queue.</td>
<td>The software was unable to add the analysis to the GCOS publishing queue. Use the GCOS Manager software to view and troubleshoot the publish error.</td>
</tr>
<tr>
<td>The number of image files found did not match the expectation to create the intensity file: &lt;file_name.CEL&gt;</td>
<td>The software must be told the number of exposures (1 or 2) that the scanner is acquiring for the analysis. This value is configured in the &quot;Number of image scans&quot; field of the Workflow Options dialog.</td>
</tr>
<tr>
<td>Analysis completed with errors.</td>
<td>This message is given at the end of an analysis run to indicate that error messages were generated during the analysis run.</td>
</tr>
<tr>
<td>Failed to align image file: &lt;filename.DAT&gt;</td>
<td>The software was not able to determine the location of the checkerboard alignment controls for the file &lt;filename.DAT&gt;. One cause may be due to the file being opened for display - the software can’t analyze a file that is open.</td>
</tr>
</tbody>
</table>
Q. What are the outputs of the algorithm used to merge short and long exposure acquisitions?

Table 5.3
HT Image Reader Generated Software Messages

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Failed to create the intensity file: &lt;filename.CEL&gt;</td>
<td>The software was not able to create the intensity file named &lt;filename.CEL&gt;. The most likely cause is if the CEL file is open in another application such as GCOS.</td>
</tr>
<tr>
<td>Failed to analyze the intensity file &lt;filename.CEL&gt;...</td>
<td>The software was not able to compute the CHP file for the associated CEL file. The message will also contain a description of the error from the CHP generation algorithm.</td>
</tr>
<tr>
<td>Warning: The summary statistics could not be calculated for the intensity data. Check the orientation of the data.</td>
<td>The software has detected that the orientation of the data may be incorrect. View the CEL file within the GCOS software to verify that the data is not rotated or flipped to the incorrect orientation. If this has occurred then use the Tools → Image... command to correct the problem and reanalyze the data.</td>
</tr>
<tr>
<td>Checking the analysis results.</td>
<td>This indicates that the software is about to check user specified values against user specified boundary conditions.</td>
</tr>
<tr>
<td>Unable to perform the results checks. You must specify the parameters.</td>
<td>The software is unable to check the boundary conditions as the parameters have not been defined for that array type. You must specify the parameters prior to analyzing data.</td>
</tr>
<tr>
<td>The analysis results are within the specified bounds.</td>
<td>The values being checked are within the specified bounds.</td>
</tr>
<tr>
<td>The analysis results are outside the specified bounds.</td>
<td>The values being checked are outside of the specified bounds. In this case the workflow for the well stops (the publishing event does not take place) and an error is generated. If the email notification system is in place the error message will be emailed to the configured user.</td>
</tr>
</tbody>
</table>
The following table describes the messages produced by the software (Table 5.4):

**Table 5.4**

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Dual Scan Migration: Median Intensity=</td>
<td>The median intensity of the features associated with the long exposure.</td>
</tr>
<tr>
<td>Dual Scan Migration: Max Extr Intensity=</td>
<td>The maximum intensity after extrapolation associated with the long exposure.</td>
</tr>
<tr>
<td>Dual Scan Migration: %Saturation=</td>
<td>The percentage of features that were saturated.</td>
</tr>
<tr>
<td>Dual Scan Migration: Slope=</td>
<td>The slope of the intercept line.</td>
</tr>
<tr>
<td>Dual Scan Migration: CC=</td>
<td>The correlation coefficient for the line.</td>
</tr>
<tr>
<td>Dual Scan Migration: N=</td>
<td>The total number of features used to fit the line.</td>
</tr>
<tr>
<td>Dual Scan Migration: Outliers=</td>
<td>The number of outlier points relative to the line.</td>
</tr>
</tbody>
</table>

- Q. What are the outputs of the algorithm used to compute the intensity data summary statistics that are used to check the alignment of the acquisitions?

The following table describes the messages produced by the software (Table 5.5):

**Table 5.5**

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Registration: Failed= (%), Available=</td>
<td>The number and percentage of features checked that failed the threshold test.</td>
</tr>
<tr>
<td>Outliers: Number= (%), Available=</td>
<td>The number and percentage of features called outliers.</td>
</tr>
<tr>
<td>Dim Features: Number= (%), Available=</td>
<td>The number and percentage of control features that should have been dim but failed the threshold test.</td>
</tr>
</tbody>
</table>
Q. What are the different library files used by the software? What do they contain?

The library files used by the software are (Table 5.6):

### Table 5.5
**Outputs of the Algorithm**

<table>
<thead>
<tr>
<th>Message</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>Bright Features: Number= (%), Available=</td>
<td>The number and percentage of control features that should have been bright but failed the threshold test.</td>
</tr>
<tr>
<td>NonSynth Features: Number= (%), Available=</td>
<td>The number and percentage of non synthesized features that should have been dim but failed the threshold test.</td>
</tr>
<tr>
<td>Oligo: Median B1=, Median B2=</td>
<td>The median intensity for the B1 and B2 control features.</td>
</tr>
<tr>
<td>NonSynth: Median=</td>
<td>The median intensity for the non synthesized features.</td>
</tr>
<tr>
<td>Thresholds: Dim=, Bright=</td>
<td>The thresholds used in the test.</td>
</tr>
</tbody>
</table>

### Table 5.6
**Library Files used by the Software**

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>CDF</td>
<td>Chip Description File. This file contains the mapping between feature location and function. As an example it will list all of the PM and MM probes for each probe set on the array.</td>
</tr>
<tr>
<td>CIF</td>
<td>Chip Information File. This file contains analysis parameters associated with the array. This information is loaded into the GCOS database.</td>
</tr>
<tr>
<td>GRC</td>
<td>GRid Control. This file contains the list of bright and dark control features.</td>
</tr>
<tr>
<td>GRD</td>
<td>GRid file. This file contains information about how to grid the acquisition files.</td>
</tr>
</tbody>
</table>
• Q. The scan data directory is set to the GCOS data directory, will this cause a problem?
  Yes, the software will not be able to function with this configuration and may result in a runtime error or crash.

• Q. If I close the HT Image Reader software while data is being analyzed will this stop the analysis?
  No, the HT Image Reader software instructs the GCOS server to perform the analysis and only displays the status messages generated during the analysis.

• Q. Can I stop an analysis once it has been initiated?
  No, once the analysis has been initiated it cannot be interrupted.

• Q. The GCOS software lists a DAT file for each well which is marked as being archived. Is a DAT file created that represents the entire array?
  No, the array is divided into multiple sub-regions with one or two acquisitions (for different exposure times) per sub-region. Data is merged at the feature intensity level (CEL file level). The GCOS software requires a parent DAT file entry in the database associated with the merged CEL file. To allow the CEL file to exist within the GCOS data management system a record in the database was created for a non-existent DAT file. So as not to allow the GCOS software to open the DAT file, the file was marked as being archived.

• Q. Where do the data files get stored on the GCOS system?

<table>
<thead>
<tr>
<th>File Extension</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>PSI</td>
<td>Probe Set Information. This file contains the list of probe set names and the number of probe pairs for each probe set on the array.</td>
</tr>
<tr>
<td>SMD</td>
<td>Sub-iMage Dimension. This file contains the dimensions of each acquisition region. Included is the number of rows and columns and upper left row/column position for each acquisition region.</td>
</tr>
<tr>
<td>APM</td>
<td>HT Array Plate Mapping. This file contains the mapping between well and probe array type.</td>
</tr>
<tr>
<td>IPP</td>
<td>Image Processing Parameters. This file contains the flag indicating whether the acquisitions should be flipped prior to analysis.</td>
</tr>
<tr>
<td>MDL</td>
<td>This is the model file for genotyping arrays. This file may or may not exist.</td>
</tr>
</tbody>
</table>
All acquisitions for an HT Array Plate are stored in a sub-directory of the GCOS data directory. The name of the sub-directory is the plate identifier (barcode). This sub-directory will contain the acquisition files (DAT) and intensity files (CEL) for the acquisition files and a file named PLATE_TYPE.INI. When the data is merged together, for a given well, a single CEL file is created in the GCOS data directory.

• Q. How do I archive the acquisition data for an HT Array Plate?
Archiving of the merged CEL file should be performed using the archiving function in the GCOS Manager software. For the acquisition data, archive the entire plates sub-directory (see the question above) to your archival system. Keep the files in the sub-directory and do not rename the sub-directory.

• Q. What is the format used for naming acquisition files?
The following describes the format of the file name for the DAT files produced by the acquisition software. This is the format required by the HT Image Reader software.

    <barcode>.<well>.<feature dimension>.<#subimage rows>.<#subimage cols>.<objective>.<filter set>.<exposure time>.<subimage index>.DAT

where

    <barcode> is the barcode value as prompted by the acquisition software.
    <well> is the name of the well. E.g. “A01”, “A02”, etc.
    <feature dimension> is the size of the feature. E.g. 8m for 8 micron.
    <#subimage rows> is the number of sub-images in the vertical direction (Y) created for each well.
    <#subimage cols> is the number of sub-images in the horizontal direction (X) created for each well.
    <objective> is the objective of the scan
    <filter set> is the filter set of the scan
    <exposure time> is the exposure time of the scan in milliseconds
    <subimage index> is the index to the sub-image.

The delimiter used between each data value is assumed to be a ".".
Appendix IV – Workflow

Workflow

The Affymetrix HT Image Reader software Suite, together with the integration with the GCOS Server system, provides a workflow for the analysis and management for the Affymetrix GeneChip HT Array Plates. The workflow of the system is defined as:

**Acquisition Detection and Transfer to the GCOS Server**

The HT Image Reader software monitors the directory used by the scan control software to store its acquisition data. When an acquisition file is created the software moves the data file to a sub-directory under the GCOS Server's data directory. The name of the sub-directory is the value of the plate identifier (plate barcode).

When all of the acquisition files associated with a well have been transferred to the GCOS Server the next steps in the workflow are performed.

This step in the workflow is managed by the HT Data Transfer Tool software; see *HT Data Transfer Utility* on page 101.

**Creation of GCOS Sample and Experiment Objects**

For each well that is processed a unique GCOS Experiment and Sample object is created. The attributes of the experiment and sample objects are defined in *Appendix I – GCOS Objects* on page 75.

These objects may be created in advance using the *Well to Experiment Mapping* on page 67. This and the remaining steps in the workflow are managed by the HT array analysis software; see *HT Image Reader* on page 49.

**Analysis of Individual Acquisition Files**

For each of the acquisition files associated with a well the software performs the following 3 image processing functions.

1. Image Flip - The data in the acquisition file is flipped horizontally.
2. Grid Alignment - The identical algorithm implemented in the GCOS 1.2 software is used to determine the four corners of the hybridization area within the acquisition file.
3. Intensity Extraction - The identical algorithm implemented in the GCOS software is used to compute an intensity value per feature.

**Merging of Short or Long Exposure Data**

Once each acquisition file is processed as described above, the software merges the data for the short and long exposures (separately). The data is merged by performing a simple union of data from all acquisition files associated with an exposure.
Integration of Short and Long Exposure Data (for dual exposure acquisitions)

The final step in creating a GCOS intensity result (CEL file) is the integration of the data from the short and long exposure. The intensities from the short and long exposures are combined using the following steps:

1. Determine the slope and intercept, given a set of points that are below the saturation intensity, and above the median intensity in the high intensity data.
2. Replace each saturated intensity value with an intensity that is extrapolated from the low intensity value, given the equation of the line.
3. Replace the standard deviation of a saturated cell by the slope times the standard deviation in the corresponding unsaturated scan.

The end result is a single file which stores the intensity values for the well.

Importing to GCOS Server

The next step in the workflow is to move the intensity file (CEL file) into the GCOS Server data directory and notify the GCOS Server database of the existence of the new data file. The acquisition files and temporary intensity files remain in the plate’s sub-directory.

Note: The GCOS system requires a single parent acquisition (DAT) file to be associated with the intensity (CEL) file. Since no single acquisition file exists for the HT system, a stub record is added to the GCOS Server database. The stub record (DAT file) is tagged as being archived so that a user cannot attempt to open it in the GCOS software.

Invoking GCOS to Analyze the Intensity Data

Once the intensity file is imported into the GCOS Server the HT Image Reader software instructs the GCOS Server software to perform an analysis on it. The type of analysis depends on the assay and probe array type. For expression arrays the algorithm computes a detection and signal call, and for mapping arrays allele calls and p-values are computed.

The results of this analysis are stored in a CHP file.

This step is optional.

Checking Results Against User-Defined Thresholds

The software can be configured to check certain analysis results, such as RawQ or %Present calls for expression, against user-defined minimum and maximum thresholds. See the section Results Check Options on page 54 for more information.

If the results are outside the thresholds the software terminates the workflow at this step and an error is generated.

This step is optional.
Publishing Results to an AADM Database

The final step in the workflow is to add the analysis results to the GCOS Server publishing queue. The data is not published in real time, rather it is added to the publish queue managed by the GCOS Server software.

This step is optional.

Error Reporting

If errors are generated during the processing of the analysis workflow the message associated with the error will be displayed in the HT Image Reader software. This software may be optionally configured to issue an email to a designated user when an error is generated. The error message is included in the body of the email.
This page intentionally left blank.
Chapter 6

ARRAY REPORTER

Introduction

The Array Reporter application will display the expression report statistics for all wells of a given plate. The software will allow the user to select one of several statistics for graphing in either the well graph or the bar graph format.

To use the tool simply specify the report options, graph options, select the plate and visualize the report statistics.

Report Options

The report options dialog is similar to that in the GCOS software (Figure 6.1). Within this dialog you specify the list of spike and housekeeping controls to include in the report. You must also specify the probe pair threshold (the threshold of the number of probe pairs within a probe set to be included in the report statistics) and the direction of the array (sense or anti-sense). Refer to the GCOS manual for specifying the spike and housekeeping controls.

![Report Options](image)

Figure 6.1
The Plate to Experiment Mapping window
The report options dialog is displayed using the Edit → Report Options menu item, the Ctrl+R key or the report options toolbar button.

**Graph Options**

The report options dialog provides control over the visualization of the report statistics. These options will be applied to all visualization windows.

**Colors**

There are four choices of color palettes for the well graph type - red/green, heat, red/blue and gray scale.

**Graph Type**

There are two choices of graph types - bar and well.

**Metrics**

These options determine what statistics are to be graphed and the Y axis scale range to use for the graph. There are two main types of display that are available, these are the "Plot Single Metric" and "Plot Out Of Range Indicator" displays.

When the "Plot Single Metric" option is selected the graph will display one of the following values:

- For Expression (Figure 6.2): RawQ, %Present, #Present, %Absent, #Absent, %Marginal, #Marginal, BG, Noise, Signal (all), Registration, Spike control or Housekeeping control. Only one spike or housekeeping control may be plotted and is determined by the "Spike/House Name" input and the "Control Output" selection (3', 5', middle or 3'/5'). The name of the spike or control must match that of one defined in the Report Options dialog. Refer to the GCOS User Guide for an explanation of these metrics. The registration metric is a percentage of those dim and bright control features and non-synthesized features that exceed a computed threshold.

- For Mapping (Figure 6.3): Call Rate, #AA, #AB, #BB, AFFX-5Q-123, AFFX-5Q-456, AFFX-5Q-789, AFFX-5Q-ABC or Registration. The registration metric is a percentage of those dim and bright control features and non-synthesized features that exceed a computed threshold.

The data will be graphed using a dynamically determined scale or a fixed range depending on the "Fixed Graph Range" selection. When the dynamic range option is selected (the Fixed Graph Range is not checked) then the software will determine the minimum and maximum value of the graph based on the minimum and maximum value of the data.

The other display type is the "Plot Out Of Range Indicator" option. When this option is selected the software will assign a value of 1 or 0 to each well depending on whether the
well's metrics pass the threshold criteria. The method for determining if a well passes the threshold criteria is as follows:

1. For each metric selected (check-marked) the software computes a score. The score is a function of the distance between the metric value and its closest boundary threshold value. The farther the metric value is from the threshold boundary, the higher the score.
   - Let \( L = \text{Min Threshold} \)
   - Let \( M = \text{Max Threshold} \)
   - Let \( T = (\text{Max Threshold} - \text{Min Threshold}) / 2 \)
   - Let \( V = \text{value of the metric to test. i.e. RawQ} \)
   - Let \( W = \text{weight of the metric} \)
   - Let \( S = \text{the test statistic score} \)
   - If \( V < L \) then let \( S = (L-V) * W / T \)
   - If \( V > M \) then let \( S = (V-M) * W / T \)
   - Otherwise \( S = 0 \)
   - Now constrain \( S \) to be not more than \( W \) (i.e. let \( S \) be the minimum of \( S \) and \( W \))
   - The resulting \( S \) value can range from 0 to \( W \)

2. If the sum of the scores for all selected metrics exceed the "Weight Threshold" value then the well is assigned a value of 0, otherwise the well is assigned a value of 1. A 0 value indicates that the well has not passed the threshold criteria.

In this mode the "Fixed Graph Range" options are ignored.

The "Show well labels" option provides a method to toggle between showing well positions ("A01", "A02", etc.) and the actual value within the plate graph type. Note: The actual value is displayed only with 2 digit precision.

The graph options dialog is displayed using the Edit → Graph Options menu item, the Ctrl+G key or the graph options toolbar button.
Figure 6.2
The Graph Options window for expression analysis
Reporting On An HT Array Plate

Once the application options have been specified you may perform a QC analysis on one or more HT Array Plates. Use the File → Open... menu item, Ctrl+O key or open toolbar button to specify the plate barcode. This command will display the Open Plate dialog window prompting for the plate barcode. This is the barcode (or identifier) for the array well plate.

Use the “...” browse button to display the Select Plate Barcode dialog (Figure 6.4). This dialog will list the plate barcodes that are currently stored on the system. Select the file by either typing in the barcode in the “Barcode” edit control, single-clicking on the value then clicking the Open button or double-clicking on the value.
Once a barcode is selected the report statistics will be computed for each well's analysis and a new visualization window will be created to display the results. Repeat the above steps to report on multiple plates.

**Results Visualization**

The visualization window is used to display the graph of the report statistics. The statistic defined in the graph options dialog will be displayed in either bar graph, well graph or 3D graph format.

Use the graph options dialog to change the graph options (not including the 3D graph view). The up and down arrow keys may also be used to change the metric to display when the “Plot Single Metric” option is selected.

To display the data in the 3D graph format, type the '3' key when the window is in focus. This key will toggle between the 3D format and the well/bar formats.

The report statistics for a well may be displayed by double clicking on either a well position in the well graph or bar in the bar graph. Click and drag the mouse to other positions to display the report statistics for the other wells.

The title of the visualization window is the plate barcode value and the report statistic currently being graphed.
Report Display (well graph format)

%P Display
The following example shows the visualization window (Figure 6.5) with the well graph display of %P (%Present) calls using the heat color palette.

![Image of Array Reporter visualization window showing %P](image_url)

**Figure 6.5**
The Array Reporter visualization window showing %P
**GAPDH 3’/5’ Display**

The following example shows the visualization window (Figure 6.6) with the well graph display of GAPDH 3’/5’ ratios using the heat color palette.

![Figure 6.6](image)

*Figure 6.6*  
The Array Reporter visualization window showing GAPDH 3’/5’ ratios
Report Display (bar graph format with properties)

The following example shows the visualization window (Figure 6.7) with the bar graph display of BIOC 3'/5' ratios and the report statistics displayed for well B11.

![Image of bar graph](image)

Figure 6.7
The Array Reporter visualization window showing BIOC 3'/5' ratios

Results Display (3D graph format)

The following example shows the visualization window (Figure 6.8) with the 3D graph display of %Absent calls.

Note that only one window may be showing the 3D graph format.

Use the mouse and a combination of shift, control or alt key to manipulate the viewing angle, position or zoom factor of the display.

- To reposition the graph:
  Hold the SHIFT key down, click and hold the left mouse button down and drag the mouse within the window.

- To change the scale:
  Hold the Ctrl key down, click and hold the left mouse button down and drag the mouse to the left (decrease) and right (increase) within the window.
• To spin the graphic around the Z axis:
  Hold the **ALT** key down, click and hold the left mouse button down and drag
  the mouse to the left and right within the window.

• To spin the graph around the X or Y axis:
  Click and hold the left mouse button down and drag the mouse to the left/right
  or up/down within the window.

You may select to spin the graphic continually (animation) around each axis by using the
popup menu commands. Right click within the window and select the Spin X Axis, Spin Y
Axis, or Spin Z Axis menu items to spin around each axis. The speed may be modified using
the Spin Faster or Spin Slower menu items.

Figure 6.8
The Array Reporter visualization window showing a 3D graph display of %Absent calls
## Application Menu Commands

### File

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Open... (Ctrl+O)</td>
<td>Shows the plate open dialog to allow a user to specify the plate identifier to report.</td>
</tr>
<tr>
<td>Close</td>
<td>Closes the active window.</td>
</tr>
<tr>
<td>Exit</td>
<td>Terminates the program.</td>
</tr>
</tbody>
</table>

### Edit

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Report Options (Ctrl+R)</td>
<td>Displays the report options dialog.</td>
</tr>
<tr>
<td>Graph Options (Ctrl+G)</td>
<td>Displays the graph options dialog.</td>
</tr>
</tbody>
</table>

### View

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Toolbar</td>
<td>Toggles the display of the toolbar.</td>
</tr>
<tr>
<td>Status Bar</td>
<td>Toggles the display of the status bar.</td>
</tr>
<tr>
<td>Properties</td>
<td>Toggles the display of the well properties (report statistics).</td>
</tr>
</tbody>
</table>

### Window

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Cascade</td>
<td>Cascades the visualization windows.</td>
</tr>
<tr>
<td>Tile</td>
<td>Tiles the visualization windows.</td>
</tr>
<tr>
<td>Arrange Icons</td>
<td>Arrange visualization icons.</td>
</tr>
<tr>
<td>&lt;visualization windows&gt;</td>
<td>Each visualization window will have a menu item that will bring the window to the top of the display.</td>
</tr>
</tbody>
</table>

### Help

<table>
<thead>
<tr>
<th>Command</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>About...</td>
<td>Displays the about dialog showing the application name and version.</td>
</tr>
<tr>
<td>Help</td>
<td>Shows the help page.</td>
</tr>
</tbody>
</table>
Toolbar Buttons

- **File → Open** menu command. Shows the plate open dialog to allow a user to specify the plate identifier to report.
- **Edit → Graph Options** menu command. Displays the graph options dialog.
- **Edit → Report Options** menu command. Displays the report options dialog.
- **Help → About...** menu command. Displays the about dialog showing the application name and version.

**Hot Keys**

<table>
<thead>
<tr>
<th>Key</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Ctrl+O</td>
<td>Shows the plate open dialog to allow a user to specify the plate identifier to report.</td>
</tr>
<tr>
<td>Ctrl+R</td>
<td>Displays the report options dialog.</td>
</tr>
<tr>
<td>Ctrl+G</td>
<td>Displays the graph options dialog.</td>
</tr>
<tr>
<td>Up arrow</td>
<td>Selects the previous report metric to display when the “Plot Single Metric” option is selected.</td>
</tr>
<tr>
<td>Down arrow</td>
<td>Selects the next report metric to display when the “Plot Single Metric” option is selected.</td>
</tr>
<tr>
<td>3</td>
<td>Toggle between bar/well graph format and 3-D graph format.</td>
</tr>
</tbody>
</table>
Chapter 7

HT DATA TRANSFER UTILITY

Introduction

The HT Data Transfer Utility is a Windows task tray application that continually runs on the scan control PC workstation. This application monitors the directory where the HT Scanner software stores the image data files generated during acquisition and transfers the data files to the GCOS Server for analysis.

With this software, transfer of acquisition files occurs in parallel to scanner acquisition. This eliminates the data transfer step when invoking an analysis using the HT Image Reader application.

Task Tray Menu

The following menu items are available on the task tray icon (right click on the task tray icon to view the menu items).

<table>
<thead>
<tr>
<th>Command</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>About</td>
<td>Shows the about box for the application.</td>
</tr>
<tr>
<td>Options...</td>
<td>Shows the options dialog.</td>
</tr>
<tr>
<td>Start Data Transfer</td>
<td>Starts the process for monitoring the scan data directory and transferring data when detected.</td>
</tr>
<tr>
<td>Stop Data Transfer</td>
<td>Stops the data transfer monitoring process.</td>
</tr>
<tr>
<td>Exit</td>
<td>Terminates the application.</td>
</tr>
</tbody>
</table>
OPTIONS

The options dialog allows the user to view and modify the application options. The available options include:

- Scan Data Directory: This is the directory where the HT Scanner Console software stores its acquisition files. The HT Data Transfer Utility will monitor the activity of this directory and transfer all acquisition files, upon completion of the scan, to the GCOS data directory. The scanner scripts all place .dat files into the D:\DAT_Files directory.

- GCOS Server: This is the name of the Windows server hosting the GCOS Server software.

- Initiate data transfer upon startup: When selected, the software will start the data transfer monitoring process upon startup (when a user logs on to the Windows system). See the workflow description for more information about the monitoring process.

Directory Monitoring

The software monitors the presence of acquisition files produced by the HT Scanner Console software in its data directory. When the monitoring process is turned on, the software will transfer all acquisition files to the GCOS data directory.

Use the Start Data Transfer or Stop Data Transfer menu items to turn on and off the monitor process.

The workflow for the monitoring process consists of the following:

- Monitoring the “Scan Data Directory” (specified in the Options dialog) for the presence of acquisition files (DAT files).

- When acquisition files are detected, the application moves them to a sub-directory of the GCOS data directory. The software will create the sub-directory as required. A different sub-directory is created to store the acquisition files for each HT Array Plate. The name of the subdirectory is the barcode (or plate identifier).

- When all acquisition files for a given well are moved to the sub-directory, the software invokes the HT Image Reader software and instructs it to initiate the analysis. The analysis is initiated only if the proper settings are configured in the HT Image Reader software (see the “Auto Invocation Parameters” options in the Workflow Options dialog in Analysis Options on page 50).
Index

A
AADM database
  publishing results 87
AADM schema and SDK 77
Analysis options 51
Array Reporter
  colors 90
  graph type 90
  menu commands 99
  metrics 90
  options 90
  report display 95
  report options 89
  reporting on a plate 93
  results visualization 94

B
Barcode
  renaming in HT Image Reader 70
Buttons
  Unload 34
  UnLoad Plate 34

C
Cleaning 47
Conformity
  declaration 15

D
Data access
  HT Image Reader 77
Deleting acquisitions 71

E
E-mail alerts 57
Error reporting in HT Image Reader 87
Expression exporter SDK 77

F
Files SDK 77

G
GCOS experiment
  HT Image Reader 75
GCOS sample
  HT Image Reader 76
GCOS SDK 77

H
Hazards
  electrical 10
  ergonomic 10
  general 9
  mechanical 9
HT Array Plate 49, 51, 67, 83, 85
HT array plate
  scanning 35
HT Data Transfer Utility
  task tray menu 101
HT data transfer utility
  directory monitoring 102
HT Image Reader
  AADM schema and SDK 77
  advanced tools 70
  analysis of individual acquisition files 85
  Analysis Options 50
  analysis options 51
  analysis parameters 52
  background subtraction parameters 52
  barcode renaming 70
  checking results against user Defined thresholds 86
  creating the mapping 67
  creation of GCOS sample and experiment objects 85
  data access 77
  E-mail Alert Options 50
  error reporting 87
  Expression Exporter SDK 77
Mapping
  creating new using HT Image Reader 67
  viewing in HT Image Reader 68
  well using HT Image Reader 67
Menu commands
  HT Image Reader 71

P
  Publishing results to an AADM database 87

R
  Regulatory compliance 14
  Results check options 54

S
  Safe operation 8
  Scan tray
    scanning 35
  Scanning
    HT array plate 35
    shutting down 45
    start 35
  Specifications
    scanner 12
  Sub image indexing 63

T
  Technical support 13
  Toolbar buttons
    HT Image Reader 74

U
  Uninterruptible power supply 30
  UPS 30
  User documentation 7

W
  Well to experiment mapping 67
  Workflow status messages
    HT Image Reader 60

I
  Image display
    HT Image Reader 64
  Image file
    HT Image Reader 62
  Image manipulation 71
  Indexing
    sub image 63

L
  Laser safety 10
  Layout
    HT Image Reader 49

M
  Main command window 36, 37, 43