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Overview 

Introduction 
The ProtoArray® Prospector Imager (referred to as Imager) is a component of the ProtoArray® 
Prospector software package. The Imager allows microarray image processing for data analysis. 

The Imager combines the functions of image editor and feature signal extraction required to process 
images acquired with autoradiography or phosphorimaging methods. The Imager combined with 
ProtoArray® Prospector Analyzer provides a complete workflow for Kinase Substrate Identification 
(KSI) and Radiolabeled Small Molecule-Protein Interaction Profiling (SMI) applications using 
ProtoArray® Microarrays.  

The Imager offers the following functions: 

• Read .TIF file 

• Perform image manipulations (brightness, contrast, zoom, rotate, resize)  

• Crop image to the desired size 

• Read .GAL (GenePix Array List) file, position grid/subarrays on the image 

• Analyze image, output signal values in .GPR format 

• Advanced functions include automatic grid positioning, block position adjustment 

• Identify significant hits and perform cross-array comparison along with ProtoArray® 
Prospector Analyzer  

Important 
The ProtoArray® Prospector Imager is designed for use with KSI and radiolabeled-SMI applications 
only and not for image analysis of fluorescence based applications such as protein-protein interaction 
(PPI) and immune response biomarker profiling (IRBP). The Imager does not contain functions 
specific for fluorescent scanner image analysis, such as spot shape detection. You need to use the 
microarray analysis software that is supplied with the fluorescent scanner such as GenePix® Pro. 

Imaging Arrays 
You will need a standard desktop image scanner that provides at least 50 µm resolution (>600 dpi) to 
scan the X-ray film after developing the film to produce a 16-bit TIFF file, or a phosphor screen or 
phosphorimager that provides at least 50 µm resolution when generating the 16-bit TIFF file.  

Supported File Formats 
The Imager software supports 8- and 16-bit grayscale TIFF file. 16-bit resolution is recommended 
for better analysis precision. Other image formats such as .jpg, .bmp, .gif are not supported. 

Image Analysis Workflow 
The raw image from the image scanner or phosphorimager usually requires some manipulations 
before the image can be used for signal extraction. You may need to crop the microarray image from 
the original picture, rotate, invert, or change resolution. Details of image preparation are described in 
Raw Image Preparation. 

After preparing the image of a single array, a grid of spots is overlaid onto the image, as described in 
Acquiring Signal Values. The grid is loaded from the .GAL file, which describes the location and 
identity of all spots on the ProtoArray® Human and Control Protein Microarrays. The .GAL files are 
available for downloading from ProtoArray® Central at www.lifetechnologies.com/protoarray 
through the Online Tools link under BioMarker Discovery Resources. Once the grid is aligned, 
feature signals are calculated and loaded into ProtoArray® Prospector Analyzer for data analysis. 
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Installation 

Downloading and Installing Imager 

The ProtoArray® Prospector Imager installer can be downloaded from the Life Technologies 
website: 

1. Go to www.lifetechnologies.com/protoarray. Click on Online Tools link under BioMarker 
Discovery Resources, then click the link to download the ProtoArray® Prospector software 
from the Online Tools page. 

2. Follow the instructions on the page to download the zipped executable installation file 
(Prospector_v5.2.3.zip) to your computer. 

3. After downloading the file, double-click on it to unzip the application. If your computer does 
not include the WinZip® utility, you can download a version for free from www.winzip.com.  

4. In the WinZip® window, double-click on the ProspectorSetup.exe file to begin running the 
installer. 

5. The installation program guides you through the installation process.  

6. ProtoArray® Prospector is installed in a folder in the Windows Program Files directory, and a 
submenu Invitrogen\Prospector is added to the Windows Start\All Programs menu: 
 

 

A shortcut for the software is also created on your desktop (shown below): 

 

System Requirements 
Supported Operating Systems:  Windows 2000 Service Pack 3, Windows XP Service Pack 2 

Required Software:  Windows Installer 3.0, Windows Installer 3.1 or later is 
recommended. 

 Internet explorer 5.01 or later 

Disk Space Requirements:  280 MB 
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Display Settings 
The recommended settings for use with Imager are 19”+ monitor, 1024 × 760 or higher resolution and 
true color. 

Note 
Installation of Prospector requires Microsoft.NET version 2.0 framework installed on the computer. If 
.NET is not installed, Prospector helps you download and install the framework. After the framework 
is installed, start Prospector installation again.  

Microsoft® .NET framework redistributable package installs the .NET Framework runtime and 
associated files required to run applications developed to target the .NET Framework. For details on 
the .NET framework, visit www.microsoft.com/downloads and click on .NET Framework Version 2.0 
Redistributable Package (x86) from the download page.  

Upgrading from a Previous Version of ProtoArray® Prospector 
1. Install ProtoArray® Prospector as described on the previous page. If you had previous 

versions installed, old executables are automatically removed, while data and results are 
retained. 

2. If you did not change the default setting for the location of the ProtoArray® Prospector folder 
during installation, the folder will be located at \Program Files\Invitrogen\Prospector. Result 
subfolders from previous analyses of arrays using ProtoArray® Prospector are located in the 
same location and are not overwritten. 

Automatic Update of ProtoArray® Prospector 
ProtoArray® Prospector can be configured to check for available version updates and download 
and install any newer versions.  

This feature checks the Life Technologies website for newer versions of the application. If a newer 
version is available the version information is displayed and the option is given to download the 
newer version. When the newer version is downloaded the option is given to install the upgrade 
immediately, or install the upgrade the next time the application is started.  

A manual version check can be performed by selecting the Tools > Check for software update 
option.  

To configure this feature, select the Options icon on the menu bar.  Within the Options dialog box 
select the Web Parameters tab.  Check the box labeled Auto check for version updates. This setting 
enables the software to automatically check for updates on a regular interval. If this option is not 
selected the user is still able to check for newer versions via the Tools > Check for software update 
option.  
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Getting Started 

Starting the Program 
To begin running Imager, select the program from the Windows Start Menu > Programs list, or 
double-click on the application shortcut on your desktop. 

The interface consists of a menu bar, toolbars, a status bar, an information panel, and an image 
window 

 

The main menu contains all functions to manipulate an image. Most frequent used functions are 
also available as buttons on toolbars. Move the mouse cursor over a button to see a short 
description of its function. The following sections describe typical workflows to process an image 
and explains each operation in more details. Most functions are referred to by a small picture (for 

example ), which indicates that such a function is available both as a button and a menu item. 

Main Menu 

Tool Bars 

Status Bar 

Information 
Panel 

Image  
Area 
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Image Area Manipulations 
Many image manipulations are done with the mouse. The keyboard may be also convenient for some 
operations, such as grid position adjustments. Details for each manipulation are described below. 

Modes of the Image Area  
There are four modes of image area manipulation, which affect appearance of the image area and the 
way mouse operates. Use the toolbar buttons shown below to select the modes: 

• Hand Tool  

In this mode, the mouse drags the image, scrolling the image over the image area. 

• Magnify Tool  

In this mode, the mouse is used to zoom in on the image. Click once on any image point to 
zoom in. Select with mouse the image area of interest to zoom to that area. 

• Array Mode  

This mode is used to position a grid of spots on the image. A standard ProtoArray® contains 
48 blocks of spots. When the grid is first loaded from the .GAL file, all blocks are selected. To 
select a single block, click on the block with the left mouse button. To select multiple blocks, 
hold the Shift key and click or you can hold the left mouse and drag the cursor over the 
blocks. To select all blocks, click outside the grid area. You may also use menu commands to 
select/unselect blocks. 

Selected blocks may be dragged with the mouse or keyboard arrow keys. Corners and sides 
of block have “handles” to stretch/rotate a block or the whole grid, if necessary. 

• Select Mode  

This mode is used to select a part of the image. Two types of selection are available: 

• Normal 

With this style selection, the rectangle size is selected with mouse. 

• Fixed size.  

With this style selection, the size is specified in pixels, and only selection rectangle 
position and angle may be changed with the mouse. This style may be convenient if you 
know the physical size of array (1’x3’ for a standard ProtoArray®) and image resolution. 
For example, if the resolution is 600 dpi, set selection size to 600 × 1800 pixels to select the 
whole array. 

To adjust selection angle, press and hold the Ctrl key and drag with mouse any angle of 
the selection rectangle as shown below: 
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Keyboard Hot Keys 
The keyboard hot keys are listed below: 

Key Function 

Ctrl + Zoom in 

Ctrl - Zoom out 

Ctrl * Zoom to screen 

Arrows (←↑→↓) Move selected block(s) by 
1 pixel 

Ctrl Arrow Move selected block(s) by 
10 pixels 

Ctrl +A Select all image 

Ctrl + D Deselect image 

Ctrl + Mouse Rotate selection 

Ctrl + O Open project 

Ctrl + S Save project 

Ctrl + Z Undo 

Ctrl + Y Redo 
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Raw Image Preparation 

Introduction 
The raw image from the film scanner or phosphor imager usually contains images of several arrays. 
The various steps involved in the image preparation are: 

• Invert colors to white on black, if necessary 

• Crop a single array image 

• Correctly orient the image on the screen 

Preparing the Image 
To prepare the microarray image for analysis: 

1. Start ProtoArray® Prospector Imager from the Windows Start menu: Start > Programs > 
Invitrogen > Prospector > Prospector Imager or double-click on the application shortcut on 
your desktop. 

2. Open .TIF image file using the  button or select Open\Image from the File menu 

3. Select the image in the Open dialog. 

4. Adjust the visual appearance of the image using Image Parameters  window, if necessary 
by adjusting the image resolution or brightness/contrast feature. Note that this function only 
affects a visual appearance of the image and does not change pixel intensities.  

 

5. Invert the image using the invert button  from the toolbar. This switches the image to 
negative and back, which sometimes helps to visually identify obscure feature spots. Note that 
this function only affects the visual appearance of the image and does not change pixel 
intensities. Use the Save Inverted Image As… function to invert the actual pixel values. 

6. Using the Hand Tool  from the toolbar, drag the image with the mouse to the center of the 
area of interest.  

7. To adjust the zoom level, use the Magnify Tool  from the toolbar and use the mouse to 

select the image area to magnify. You may also use  and  buttons.  
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8. Rotate image with rotate tool  on the toolbar such that the array image is vertical and the 
barcode is located at the bottom. 

 

9. Switch to Select Mode tool  to set the selection style. We recommend setting the selection style 
to Fixed Size and specify selection size 1800 × 600 or 600 × 1800 depending on the image 
orientation (assuming that the scanner resolution is 600 dpi and microarray slide is 1” × 3”).  

Note: If the image is scanned at a different dpi, set the fixed rectangular area accordingly. For 
example, if the image is scanned at 1200 dpi, set the fixed rectangular area to 1200 × 3600 pixels to 
cover the 1” × 3” array area. 

10. If the spots are not aligned vertically, rotate the selection rectangle by pressing and holding the 

Ctrl key, and rotating the selection angle with the mouse. Use the Zoom in tool  at this step, if 
needed. First rotate and align the rectangle against the Alignment Control Kinase spots, release 
the Ctrl key and move the rectangle to cover the whole array area. 
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11. Crop the selected rectangle which should correspond to the perimeter of the array using the Crop 

tool . 

12. Optionally you may resize image to a bigger size. This may increase signal values precision, but 
slows down analysis and increases image file size. Use Image > Resize menu command. We 
recommend stretching the image integer number of times, i.e. 3x or 4x, and constrain proportions.  

13. To save the prepared image as a .TIF file use Image | Save As… or Image | Save Inverted Image 
As… menu. Specify the file name and location. Be sure to include the barcode in the name of the 
image. 

14. You may now repeat this workflow to prepare another image or proceed to the next section for 
signal quantification. 

Note: Each function that changes the image, such as Crop, Rotate, Resize, can be undone using undo 

 and redo tools  from the toolbar. However functions that change the image appearance such 
as Zoom, Scroll or Invert do not require undo capability. 
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Data Acquisition 

Introduction 
After the image of a single array is prepared, overlay a grid of spots onto the image. The grid is 
loaded from the .GAL file (GenePix® Array List), which describes the location and identity of all spots 
on the ProtoArray® Human, Yeast, and Control Microarrays. Once the grid is aligned, feature signals 
are calculated and loaded into ProtoArray® Prospector Analyzer for data analysis.  

Acquiring Signal Values 

1. Open a prepared single-array image using the  button or select Open\Image from the File 
menu. 

2. Download the .GAL file from ProtoArray® Central at www.lifetechnologies.com/protoarray 
by clicking on the Online Tools link.  On the Online Tools page, click the link under 
ProtoArray® Lot Specific Information and use the lot number to download the array specific 
information as directed on the web page. Save the .GAL file to a specific location. 

3. Select the Array Mode tool  from the toolbar. You can also load an array list using the  
button or Open\Array List command from the File menu. A standard file open dialog opens for 
selecting the .GAL file from the appropriate location. If no array list was loaded, the screen 
automatically shows a standard file open dialog to load the array list from a .GAL file.  

 

4. Adjust a scaling factor corresponding to a resolution of your scanner, if necessary. Use menu item 
Window > Show Image Parameters > Image Resolution to specify scanner resolution (usually 600 
dpi, but may be different for your scanner). 
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5. Set the feature diameter to 190 µm using menu Array List > Block Properties… 

 

6. Using the mouse and keyboard arrow keys, adjust the grid over the image manually. Use spots 
corresponding to the Alignment Control Kinase (PKCeta) as reference spots to orient the 
microarray image. Click to select individual subarray to move, hold Shift key and click to select 
multiple subarrays (you can also hold the left mouse and drag the cursor to cross the blocks) or 
click outside the grid area to select all subarrays. Scroll through the image to ensure that the grid 
is in the proper location for each subarray. 

See Image Area Manipulations for details of keyboard and mouse operations, and Additional 
Functions for automated grid positioning tools. 

7. After the grid is adjusted properly and all features are aligned, use Save Project As… on the File 
menu to save the project (including the image, grid position and parameters for future 
references). Specify the file name and location. 

8. When all subarrays are positioned correctly over the image, select menu item Array List > Analyze 
Results… Specify the file name to store calculated signal values and select the KSI application. 

 

9. Press OK. Imager automatically opens the Analyzer component of Prospector for data analysis 
and the file is now opened and processed by ProtoArray® Prospector Analyzer. 
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10. The required PAI (ProtoArray Application Information) files for v5.0 and v5.1 microarrays are 
now included with installation of the ProtoArray® Prospector v5.2.3. Prospector automatically 
downloads .PAI files from Life Technologies ProtoArray® Central if the required file is not found 
in the Application-Lot Specific Files subfolder. 

11. Specify experiment type: Step 1 (Control Kinase) or Step 2 (Customer Kinase) for control 
microarray, or Step 3 (Buffer) or Step 4 (Customer Kinase) for experimental microarray. 

 

12. ProtoArray® Prospector Analyzer shows a summary of analysis completed in the right view. See 
Prospector manual for detailed description. You may now return to Imager to verify hits 
identified by the software are also observed on the actual image. 

 

 15 



Additional Functions 

Save Inverted Image 
The Imager assumes that zero pixel value corresponds to black color. If raw image is negative (black 
on white), you need to invert the image, changing each pixel value V to 65535-V. To do this use menu 

function Save Inverted Image, and then open this saved image. Note that the  Invert function  
only changes a visual appearance of the image (some spots are easier identified when drawn as black 
on white) and does not affect the actual pixel values, or results of signal acquisition.  

Save Project As 
A Project is a human-readable .xml file which contains links to an image and array list files, as well as 
parameters such as grid position. We recommended saving the project before analyzing results to 
simplify further verification of hits identified by ProtoArray® Prospector Analyzer.  

Find Features 

The Find Features function is available on the Array List submenu or from the toolbar  and allows 
finding one or more features with specified name or Database ID.  

 

All features with search field containing specified search text are found and listed. 
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When one or more rows are selected in the list, the corresponding spots are highlighted on the array 
image. 

 

Auto Position 

The Auto Position function is available on the Array List submenu or from the toolbar  and tries to 
automatically detect the whole grid position, size and angle. It does not adjust individual block 
positions. Protein array images are hard for automated positioning because most features have 

signals close to a background. If this function fails, you may use Undo  to restore previous grid 
layout.  

Auto Align Blocks 
The Auto Align Blocks function is available on the Array List submenu and automatically adjusts the 
position of each selected block (subarray). Imager shifts each block in every direction within one spot 
distance trying to find optimal location of the block. Position the blocks close enough before running 
this function. 
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Technical Support 

Obtaining support 
 
 

For the latest services and support information for all locations, 
go to www.lifetechnologies.com 

At the website, you can: 

• Access worldwide telephone and fax numbers to contact 
Technical Support and Sales facilities 

• Search through frequently asked questions (FAQs) 

• Submit a question directly to Technical Support 
(techsupport@lifetech.com) 

• Search for user documents, SDSs, vector maps and 
sequences, application notes, formulations, handbooks, 
certificates of analysis, citations, and other product support 
documents 

• Obtain information about customer training 

• Download software updates and patches 
 

Safety Data 
Sheets (SDS) 

Safety Data Sheets (SDSs) are available at 
www.lifetechnologies.com/support. 
 

Certificate of 
Analysis 

The Certificate of Analysis provides detailed quality control 
and product qualification information for each product. 
Certificates of Analysis are available from 
www.lifetechnologies.com 

 

Limited warranty Life Technologies and/or its affiliate(s) warrant their products as set 
forth in the Life Technologies General Terms and Conditions of Sale 
found on the Life Technologies web site at 
http://www.lifetechnologies.com/termsandconditions.  If you have 
any questions, please contact Life Technologies. 
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For support visit www.lifetechnologies.com/support or email techsupport@lifetechn.com    

www.lifetechnologies.com
2 March 2015


	For microarray image analysis
	Overview
	Introduction
	Important
	Imaging Arrays
	Supported File Formats
	Image Analysis Workflow

	Installation
	Downloading and Installing Imager
	System Requirements

	Display Settings
	Upgrading from a Previous Version of ProtoArray® Prospector
	Automatic Update of ProtoArray® Prospector

	Getting Started
	Starting the Program
	Image Area Manipulations
	Modes of the Image Area

	Main Menu
	Tool Bars
	Status Bar
	Image
	Area
	Information Panel
	Raw Image Preparation
	Introduction
	Preparing the Image

	Data Acquisition
	Introduction
	Acquiring Signal Values

	Additional Functions
	Save Inverted Image
	Save Project As
	Find Features
	Auto Position
	Auto Align Blocks

	Technical Support



