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Affymetrix Genotyping Console 4.1.2 Release Notes 

(For research use only. Not for use in diagnostic procedures.) 

 

 
Genotyping Console 4.1.2 includes the following changes and enhancements:  

1. Support for Axiom™ Genome-Wide GAL 1 Array Plate 

2. Support Axiom™ Genome-Wide EUR 1 array and advanced data analysis workflow 
3. Support Axiom™ Genome-Wide EAS 1 array and advanced data analysis work flow 
4. Support Axiom™ Genome-Wide AFR 1 array and advanced data analysis work flow 

5. Support Axiom™ Genome-Wide LAT 1 array and advanced data analysis work flow 
6. Support Axiom™ myDesign

TM
 Genotyping Array plates 

 

Installation/Upgrade Requirements for Genotyping Console 4.1.2 
1. Genotyping Console 4.1.2 supports the following operating systems: 

a. Windows XP SP3 (32-bit) 

b. Windows XP SP2 (64-bit) 
c. Windows 7 Professional SP1 (32-bit) 
d. Windows 7 Professional SP1 (64-bit) 

e. Windows 2008 Server Standard Edition R2 – SP1 (64-bit ) 
 

2. Configuring Windows 2008 Server prior to GTC 4.1.2 installation 

When installing GTC 4.1.2 on Windows 2008 Server, an error will display “You must use 
the Role Management Tool to install or configure Microsoft .NET Framework 3.5 SP1.”  

 

To address this error:  

 Cancel the GTC installation 

 Go to Start  => Administrative Tools => Server Manager 

 Click on Features  

 Click Add Features  

 Expand .NET Framework 3.5.1 Features and check the .NET Framework 3.5.1 
checkbox 

 Click Next 

 Click Install 

 After .NET is installed, install GTC 4.1.2 
 

3. Genotyping Console 4.1.2 will upgrade from previous versions 3.0, 3.0.1, 3.0.2, 4.0, and 

4.1, 4.1.1. The GTC 4.1.2 installer will remove the previous version as well as install the 
latest version.  If Matlab is installed, the installer will ask you if you would like to remove 
it.  Testing has not been performed to upgrade from GTC 1.0, 2.x.  

 
4. New and updated library files and annotation files are available and are REQUIRED for 

Genotyping Console to analyze Axiom™ arrays and other arrays.  You can download 

them through the GTC application or copy the Files in the “GTC_4.1_Analysis_Files.zip” 
folder (which can be downloaded from the Affymetrix Product Page).   

5. Use the “File->Download Library Files…”   and “File->Download Annotation Files…”

 commands to retrieve the current files.  

a. Files on a workstation that are up-to-date will not be re-downloaded.  
 

6. To save time downloading and processing library and annotation files for several 
workstations:  
Perform the download and pre-processing steps on one workstation, and then copy files 

to the other workstations. To do this: 
a. Empty or create a new GTC Library folder on the first workstation. Be sure to 

point GTC to the new Library folder with the following menu item:  

  Close any open workspace, then EDIT | Options | Directories tab.  
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b. Download the required library files(s) using GTC 
c. Download the required annotation file(s ) using GTC 

d. Copy the GTC Library folder contents to the other workstations overwriting the 
old GTC Library files. 

Note: The GTC annotation download will automatically optimizes annotation files after the 

downloading process finishes. If SQLite annot.db files are not downloaded through GTC, it is 
recommended to optimize SQLite annot.db files to make the application runs faster and prior 
to copying to multiple workstations: 

 
e. In the GTC FILE menu of the first workstation, select Optimize Annotation Files 

… and Optimize the annotation Files.  Copy the optimized files to subsequent 

workstations  

Note: It is recommended to always use the “File->Download Library Files…”   commands 

to retrieve the most current library files if you are switching from one library folder to another 
library folder.   
Note: The existing GTC 4.x analysis configuration files in the current library folder/user profile 

will be updated to the GTC 4.1.2 compatible format when GTC 4.1.2 is installed. For any 
customers that are analyzing arrays other than the default GTC supported ones,, they shall 
contact Application Support to obtain the GTC 4.1.2 compatible analysis configuration files. 

Any custom analysis configuration files shall be re-generated with the same customized 
parameters in GTC 4.1.2 using the menu option „EDIT > Genotyping Configurations > New 
Configuration…‟   

Note: The Axiom Genome-Wide CEU 1 array is the same as the Axiom Genome-Wide 
Human Array. 
Note: During the SNP 6.0 copy number analysis, some computations were incorrectly 

computing median values when Nan values occurred (A Nan value is generated by invalid 
mathematical operations (e.g., division by zero)). This has been corrected in GTC 4.1 where 
the new computations take the median of all non Nan values.  This fix has minimal impact on 

the copy number analysis results.  Among the 166 abnormal cytogenetic and cancer samples 
tested, no differences in LOH calls or CN segmentation were observed comparing the results 
from before and after the fix.  

Note: For Axiom™ myDesign™ Genotyping Arrays and Axiom™ Genome-Wide CHB Array, 
the call rate metrics will be calculated using the probe sets in the SNP list plus the 3000 
SNPQC probe sets. The posterior models file generated during genotyping will include the 

probe sets in the SNP list plus the 3000 SNPQC probe sets. The contents of the resultant 
CHP files will only contain analysis results for those probe sets included in the SNP List . 
Note: Occasionally, customers might see an error if they are performing genotyping for a 

group of Axiom CEL files that are all the same gender (either all males or all females)  and 
trying to use the generated posterior models file with a gender file including the other gender 
(female or male) for further genotyping. This error is due to the lack of presence of both 

genders and the subsequent incomplete content in the generated posterior models file. To 
avoid this issue, customers shall include both male and female samples during genotyping. 
Another workaround is to add two lines to the generated posterior models file to handle the 

incomplete content.  
GENERIC          -2,0.06,0.2,1,10.5,0.3,0   0,0.06,0.3,10,11.0,0.3,0  2,0.06,0.2,1,10.5,0.3,0    -
0.1,-0.1,-0.1,-0.05,-0.1,-0.05,0,0,0,0,0,0 

GENERIC:1          -2,0.06,0.2,1,10.5,0.3,0   0,0.06,0.3,10,11.0,0.3,0  2,0.06,0.2,1,10.5,0.3,0    
-0.1,-0.1,-0.1, -0.05, -0.1,-0.05,0,0,0,0,0,0 
 

 

The following are known issues that existed in previous versions of Genotyping Console 
and were not addressed in Genotyping Console 4.1.2: 

 
1. If a SNP list contains unconverted chromosome X SNPs (unconverted SNP: there are no 

SNP specific priors in the models file for that SNP), customers will only see 3 priors 

ellipses in the cluster graph when that SNP is displayed.  The reason is that B and A 
ellipses are super-imposed with BB and AA ellipses.  Posterior ellipses will display the 5 
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ellipses with information from study samples.  
 

 
 
 
 

2. Currently, GTC does not prevent users from manually loading models files when the chip-
type is unknown and none of the probe set ids in the snp list  is found in the models file.  
 

3. When loading cluster graph for Mapping100K array, and if the SNP list filename contains 
special characters, an unhandled exception is thrown. This error only occurs on 
Mapping100K Xba and not the Mapping100K Hind.  

 
4. Currently, the cluster graph does not check chp type compatibility. Thus, users can load 

mix-match versions of model file. Verify that the chp types are the same when creating a 

cluster graph.  
 

5. When genotyping and the user modified the snp list with an invalid column name, the 

error message does not list the required column name needed.  
 

6. If you run the Genotyping Axiom Hu array or any other array with a snp list that has no 

probe set, it will cause the application to throw an exception.  Ensure that there is a probe 
set in the snp list to prevent the error. 
 

7. There is no error is displayed when genotyping with duplicate and extra CEL files in the 
inbred file. User must verify manually that there are no duplicate and extra CEL files in 
the inbred file.  

 
8. There is no error is displayed when genotyping with an invalid hint file (e.g. invalid snp or 

cel file).  

 
9. Model files edited in MS Excel with added “” will not be accepted by cluster graph. Ensure 

that edited models file doesn‟t contain additional “”.  
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10.  GTC 4.1 does not automatically upgrade GTC 1.0/2.0 on Spanish operating system.  
When the installer prompts for a restart to continue, it does not automatically start.  

Rather the user will need to relaunch the installer to continue with the GTC install.  This is 
only on the Spanish operating system. 
 

11.  In order to see the crash, user needs to open the model file and manually change the 
content of the file or delete a certain section in the model file.  If user loads the model file 
Affymetrix provided or generated by GTC then they won't see this problem.  

 
12.  All the current genotyping analysis library files are generated based on Hg18 genome 

build. NetAffx annotation version NA 31 and above are from Hg19 genome build. When 

users view certain SNPs in cluster graph, the information indicated in the graphic area 
might be different than the annotation information available in the SNP Summary Table. 
Less than 250 SNPs will be impacted by this issue in SNP6 array. And fewer SNPs will 

be impacted by this issue in other arrays.   

 
 

13.  SNP 6.0 copy number / LOH analysis has memory leak issue.  

1) When users finish copy number analysis for 450 files, GTC needs to be closed before 
another copy number analysis is initiated.  
2) If GTC has been using over 100MB memory before copy number analysis  begins, 

GTC will fail with out of memory error. The workaround is to close other windows within 
GTC before copy number analysis starts.  
3) When users run segment reporting tool (SRT) right after copy number analysis for 450 

files, GTC will fail with out of memory error. The workaround is to close GTC after copy 
number analysis and re-open GTC to start the SRT. 

 

14.  Cancel may take long time when running copy number analysis GC batch mode for na27 
or na28 annotation files. The progress bar grays out but analysis continues until it 
finishes. 
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15.  When the user exports Genotype results for Plink using the transposed option, the 
exported tped file the dbsnp is duplicated for two probe sets (rs1462062 and 

rs12635398).  
When making a choice between probesets associated with the same dbSNP RS ids, the 
probeset that is of higher\later probe set it is used.  The picture below shows the 

duplicated probe sets. 
 

 
 
 

 
 

16.  When a SNP list is opened and sorted by dbSNP RS ID column, the ID is sorted by the 

first 6 digits, not by the absolute value.  
 

17.  In the Segment Report Tool, if the user changes Overlap with known CNV regions value 

to “zero”, the browser will display segments overlapping with the 'genomic variants'.  
However, the generated segment report file the %CNV_Overlap column will show it as 
zero.  

 

18.  On Vista Aero and Vista Basic settings, the „Select All‟ button in Segment Report Tool 
does not select all the files after unselecting a few files.  
 

The workaround is to click the OK button and then the Segment Report Tool starts to run. 
 

19.  After upgrading from GTC 3.0.2 to GTC 4.0, the user cannot open GTC 3.0.2 workspace 

in GTC 4.0. This only happens if the GTC 3.0.2 workspace is created without any data.  
 
The workaround is to create some data in GTC 3.0.2 and then upgrade it to GTC 4.0.  
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20.  When a user exports genotype results for PLINK using the Standard option contents in 
the exported ped file are sometimes displayed with as square boxes in Notepad. 

However, the PLINK export file is compatible with the PLINK tool.  
 

21.  Optimizing the annotations when there is not enough free disk space will result in the 
error “SQLite error cannot rollback – no transactive is active”. 
 

The workaround is to free up some disk space and re-download or copy the annotation 
files again.  Disk space usage will depend on the number of annotation files selected to 
optimize. 

 

22.  When you open the annotation file within GTC software, the application will be very slow 
or hang if you click on the Find button to search for information.   This also happens when 
scrolling or sorting through the annotation table.  

 
Do NOT click the Cancel button once the “find” function has initiated.  Instead, please use 
the task manager to kill the GenotypingConsole.exe process.   

 
23.  If the pedigree template does not have the attribute for Sex as Male, Female or Unknown 

and Affection Status as Unaffected, Affected or Unknown, there is no warning about the 

missing information while exporting in PLINK format.  The application will assign the 
value 0 to these attributes. 
 

24.  In the SNP list, SNP Summary table, and SNP cluster table, the order of SNPs in the 
Probe Set ID column is not the same between GTC 3.0.2 and GTC 4.0.   
 

However, when the CHP file is exported using this SNP list, SNP Summary table of the 
SNP cluster table below the cluster graph, the SNPs in the exported file are listed in the 
same order as that in GTC 3.0.2.  

 
25.  SNP5 data generated from GTC 1.0 will not display the attributes in the cluster graph. 

However, SNP6 data generated from GTC 1.0 works fine.  There is no workaround for 

the SNP5 data generated from GTC 1.0.  
 

26.  When adding a large amount of files (ARR/CEL), use the “Select Directory” option 

instead of the “Select Files” option.  If you use the “Select Files” option, an error will occur 
“… CEL file from x:\directory does not exist…” 
 

27.  There are some rounding differences between GTC 3.0.2 and GTC 4.0.  The differences 
are:  

 There are rounding differences in Contrast QC (Random), Contrast QC (Nsp), 

Contrast QC (Sty), Contrast QC (Nsp/Sty Overlap).  However, the Contrast QC 
and Call Rate are the same in both versions. 

 There are rounding differences in CNV Signal.  However, the Call and 
Confidence call are the same in both versions.  

 There are rounding differences in the call_rate and hom_rate columns for the 
SNP6 CHP Summary Table.   

 

28.  There are rounding differences between GTC 4.0 32-bit and GTC 4.0 64-bit.  The 
differences are:  

 Copy Number for 100K/500K has differences in Log2Ratio, 

HmmMedianLog2Ratio, and NegLog10PValue. The CNState is the same.  

 Genotyping for SNP6 has rounding differences in Signal B. 
 

29.  During SNP list creation, when SNP Call Rate threshold is set as “.9” as search criteria, 

no SNPs will be returned. The workaround will be to use “0.9 instead of “.9” as criteria.  
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18.  Users cannot unzip a Workspace > 4GB.   
Users can zip a Workspace larger than 4GB, but will be unable to unzip the    

Workspace. To avoid this issue, create and zip a Workspace that is not larger than 
4GB in size. 

 

19.  If a user opens a “.bed” file in Microsoft Word or Excel and concurrently opens the 
CNVCHP file in GTC, the GTC application only shows 1 column.  This is because the 
.bed file is in use.  To see all columns in GTC, a user can open the .bed file in Notepad at 

the same time.  Alternatively, close the .bed file in Microsoft Word or Excel and the 
columns will be displayed in GTC.  

 

20.  QC thresholds are updated for only one library path for each user profile.  
If users have more than one library path for a user profile, the QC metric will only be 
updated for the default library file folder.  You will need to change the library file path to 

ensure that the other library paths are updated  
 

21.  If you select the CHP vs. CHP Concordance Check, the selected batch node is not listed 

in the pull down box.   
 
22.  In the application, there may be inconsistencies in the display of numbers, e.g.05 vs. 

0.05.   
 

23.  If you select an invalid annotation file, the error message “Failed to open the annotations” 

appears.  Select the correct annotation file and the error will not appear.   
 

24.  If file names are too long, you will not be able to view all the region information in the 

Heat map window.  
 

25.  In very rare occasions, when samples have abnormal karyotypes XXYY or XXY where 

XX is a normal diploid heterozygous, GTC reports the total LOH in the non -PAR regions 
of chromosome X. This is because the BRLMM-P-Plus algorithm defaults to calling all 
SNPs in the non-PAR region of the Chr X as a homozygous if a chromosome Y presents. 

If you see gender calls as unknown in the Karyoview Legend after you run segment 
reporting tool for these abnormal samples, the LOH calls on chromosome X shall be 
taken with low expectations.    

 
26.  If a user uses SNP 6.0 CNCHP files from GTC 3.x and runs the SRT in GTC 4.0 and 

above, the following error will occur.   

 
“Annotation file <location>\GenomeWideSNP_6.na<version of the annotation file when 
CNCHP files were generated>.annot.db not found.  This error occurred because the 

same version of SQLite annotation files are not installed.  
 
Please go to Affymetrix.com and download the earlier versions of annot.db files to the 

library folder.  Then use the “File->Optimize Annotation Files…” menu option to create 
the indexed annotation file. 

     

The earlier versions of annotation files are located on the Product & Services page> 
Arrays > Genome-Wide Human SNP 6.0 > Tools & Data under the “Archived NetAffx 
Annotation Files” heading.  

Same rules apply to 100K/500K SRT analysis. GTC 4.0 and above will need NA24 
version of the 100K/500K annot.db files for 100K/500K SRT analysis. The NA24 
version of the annot.db files are located on the Product & Services page> Arrays > 

Human Mapping 100K Set (or Human Mapping 500K Array Set) > Tools & Data under 
the “Archived NetAffx Annotation Files” heading.  
 

27.  When you add CNCHP files to a batch, the error “No CNCHP files added or 0 files 
imported” appears if one or more CNCHP files are of size 0kb.  Check the size of the 
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CNCHP files you are attempting to add.  After removing the bad CNCHP file(s), you 
should be able to add the CNCHP files to the batch.  

 
28.  This issue affects the 100K/500K mapping arrays with respect to updating the workspace 

with results files following unpaired CN + LOH runs.  An unhandled exception error will 

appear if you run an unpaired CN + LOH analysis for a data set which contains 
more “sample files” than the “reference files”  

 

29.  SNP 6.0 Intensity files which have previously QC‟d with Birdseed V2 must be added 
together with their accompanying GQC files to a data set.  Otherwise, the application will 
display the error message “QC metrics cannot be displayed until the CEL files have been 

QC‟d”. The same message will be displayed when double clicking on the “All” Intensity 
data group icon. A message “Intensity Data results are not available” will be displayed 
when double clicking on the “In Bounds” and “Out of Bounds” Intensity data group icons.  

 
If you receive these error messages, please follow one of these procedures:  
For files generated in GTC v2.1 or later:  

 Locate the GQC files and copy them into the same directory as the 
intensity files. 

 Add intensity and GQC files simultaneously, making sure the checkbox 
“Auto-QC Intensity files” is selected. 

 
For files generated in GTC v2.0 or earlier:  

 Locate the GQC files and copy them into the same directory as the 

intensity files.  

 Add intensity and GQC files simultaneously, making sure the checkbox 
“Auto-QC Intensity files” is selected. 

 Perform QC again to incorporate the Contrast QC metric.  Otherwise, the 
warning message “QC metrics will be displayed.  Since GTC 2.0 and 
earlier did not have the algorithm to generate Contrast QC data, re-
invoking the QC step completes the QC process. 

 
30.  In the very rare case of encountering a corrupt or “bad” CEL file, QC may fail.  

 

a.   If a corrupt CEL file is part of a group of CELs being QC‟d, the corrupt CEL may 
halt the QC process with an “Unhandled Exception” error message, and neither 
the bad CEL nor the subsequent files to be QC‟d will have GQC files successfully 

generated for them.   

   
 

b. The bad CEL file will be identifiable in the last line of the status messages list at 

failure, which will say: “Calculating the QC metrics for:” and the name and file 
path of the bad CEL file.  

 

c. Corrupt CEL files which cause QC step to fail must be removed from the system, 
as GTC software will attempt to QC them again if new data is imported into the 
Data set. This will fail the process again even though the new CEL files might be 

fine. 
 

d. You must also delete the XML/ARR file and the GQC file of the bad CEL if you 

need to remove a bad CEL file. This is because the "Auto-Add" automation 
feature will re-add bad CEL files if the XML/ARR file or GQC file is still in the data 
set. 
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e. In the very limited number of examples identified, corruption of the files has been 

seen after a transfer of the original files  
 

31.  In GTC 4.1 and above, there is an option to use a proxy server.  A proxy server requires  

authorization to access the internet, you may be unable to download files from NetAffx. 
You can either disable or enable the proxy server setting.  

 

32.  Renaming Results Groups level batch folders only renames groups in the GTC 
workspace. The Windows file system folder does not get renamed as part of this action.  

 

33.  PDF exports of the cluster plot of large SNP lists are limited to a workstation's disk drive 
capacity. Each SNP‟s cluster plot is temporarily stored in a PNG file in the user‟s system 
temporary directory prior to the PDF file being created, thus there must be enough disk 

space for the storage of all of these files.  
 

34.  The cluster graph feature is designed to function with relatively small SNP lists  of up to 

200,000 SNPs. The data for each cluster plot is loaded into memory. Too many SNPs in 
a SNP list will exceed the workstation‟s memory capacity.   

 

35.  When exporting Genotype Results or CN/LOH results, be sure to use a unique name to 
avoid overwriting previously exported files.  

 

36.  When the Browser is started from within GTC, the Browser Help file will fail to open the 
first time it is used after creating a new profile. Close both GTC and the Browser. Start 
the Browser from the Start > Programs > Affymetrix > 'GTCBrowser' icon. Open the 

Browser's Help file.  
 

37.  The CNCHP and LOHCHP files for the 100K or 500K arrays do not  indicate if the results 

were derived using Normal or Median normalization. 
 

38.  If you load two different CNCHP files with the same name (loaded from different folders), 

they will display on top of each other in the Browser. Always give results files unique 
names, even if separate folders are used. 

 

39.  On some workstations it is possible for the copy number analysis to fail the very first time 
it is performed. Restart the analysis a second time.  

 

40.  The GTC browser and Toronto/UCSC browsers have a difference in one vs. zero based 
coordinates.  

 

41.  The shading used for denoting the centromeric and acrocentric regions in the cytobands 
are not exported to a PDF file.  
 

42.  Older versions of GTC are allowed to install over newer versions. For example, 2.1 will 
install over 4.0.  


